• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 385
  • Last Modified:

Cannot delete a folder even though permissions appear correct

Windows Explorer in Windows 7 Professional is refusing to allow me to delete a folder, even though I am logged on as the user who owns the folder.

I am trying to delete a folder whose full path is

c:\Users\Michael\Documents\1 Bus -- journalism to '05\NY Wine Experience, 10-2005\Old drive\

When I right click the folder in the Windows Explorer folder list and choose Delete, the system displays a progress panel saying it's moving the folder to the Recycle Bin.  But then an error message appears in a window titled Folder Access Denied.  The error text is "You need permission to perform this action.  You require permission from Maceo\Michael to make changes to this folder . . . "

This message appears even though I am logged on as Maceo\Michael.   Task Manager's Users tab reports that user "Michael" is the only user on the machine and has a status of "Active" with a Session "Console."  

When I right click the folder and choose Properties > Sharing tab > Share button, the "Choose People to Share with" list already includes an entry with Name = Michael and Permission Level = Owner.

Why on earth can't the owner of a folder delete the folder?

0
MichaelKnoll
Asked:
MichaelKnoll
3 Solutions
 
Ivano ViolaSystem AdministratorCommented:
Very weird. Try taking ownership of the folder...again. Right-click the folder and select Properties - Advanced - Owner tab. I guess you will be listed as the current owner. Change it to the Administrators Group. Click Apply then OK. See if you can delete the folder.
If this doesn't work go back and make yourself the owner and try it again. Reapplying the permissions may work.

Let us know how it goes.
0
 
puterg33kCommented:
Try r-clicking on the file > properties > Security tab.  Press the Advanced button on the bottom and then select the owners tab.  Press the Edit button and make sure your user is selected as the owner.  Check the box to "replace owner on sub-containers and objects"  and press OK

Go back into the Security tab and press advanced again.  This time select the "Change Permissions" button.  Verify that your user is listed with full control and check the box to " Replace all child object permissions with inheritable permissions from this object"  and Press OK

Try deleting the folder now.  If that doesn't work I would try deleting the sub folders and files in smaller chunks.
0
 
MichaelKnollAuthor Commented:
I found an awkward solution of my own.  The folder I was trying to delete contained dozens of subfolders and several thousand files buried in several layers of subfolders.  By trial and error, I discovered that if I drilled down far enough in the hierarchy of subfolders, I could get down to a level of subfolder that Windows Explorer would allow me to delete.  If I deleted most or all the subfolders, then I could work my way up the hierarchy and delete their parent folders.  In this fashion, I laboriously deleted folders from the bottom of the drill-down hierarchy and working my way up each branch of the subfolder tree.  Something seems to be wrong with the operating system, because one would think that if my account had the permission to delete all the subfolders within a given folder, then it ought to have been able to delete the folder itself.  

Earlier versions of Windows had a bug that caused Windows Explorer to behave erratically and return incorrect error messages when it tried to perform oprations on folders that contained files or folders with paths that were too long.  I suspect that Windows 7 has similar bugs.
0
 
SCCMCanuckNetwork AnalystCommented:
Hi Micael,

I have attached a screenshot outlining the clicks you should take to fix this problem. If you have any question let me know. Once you have taken owenership and propgated the permissions to the subfolders and files you should be able to delete no problem. I have had this issue numerous times already and it should work.

Thanks
Taking-ownership-of-a-file.PNG
0
 
MichaelKnollAuthor Commented:
I found an awkward solution by myself and fixed the problem before I received anybody else's suggestions.  

I had already tried a solution similar or identical to Ivanoviola's, but it didn't work, so I'm awarding only minimal points to that solution.

Both puterg33k and Binarymime pointed out that Folder Properties > Security Tab > Advanced button > Owner tab > Edit button reveals a pane with the checkbox "Replace owner on subcontainers and objects."   Had I used this, it might have fixed the problem.  I'm not sure, and I fixed it before I could try, but it sounds plausible so I am awarding points anyway.

Thanks, folks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now