Delphi Bug Reporting - Erratic IDE Control Click

We have recently upgraded a massive application from Delphi 7 to Delphi 2009.

Sometimes Ctrl+Click in the IDE editor does not take you to the correct line where the definition (of what you clicked on) is declared.  BUT it does open up the file and puts the cursor at the end of the file.  

I tried Build All but that didn't work.

Hah - I just went File Close All and restarted Delphi and then re-opened my project and it worked.  

Hmm I think I might have edited the code that I clicked on whilst debugging the application.  I certainly didn't edit the file that contained the definition.  I will keep an eye on this in future to see if that was it.  Actually what I did should not have caused this behaviour (at least based on my extensive Delphi 7 experiences).

Still this is odd behaviour isn't it?  I mean the identity was highlighted as I put the mouse over it AND when Ctrl+clicking it took m to the right file Bu just the wrong place.

Points go to anyone who can shed some light on this subject (even though I sort of answered it).  Is this a bug?  Shoudl I report it to embacadero?

Actually better still - let me know if anyone else has experienced similar behaviour.

FYI I found one here...
http://www.experts-exchange.com/Programming/Languages/Pascal/Delphi/Q_23956678.html 

LVL 1
enigmasolutionsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheRealLokiSenior DeveloperCommented:
I'd check that the file has correct CR/LF pairs at the end of each line
Perhaps if it only had Linefeeds, then it may still look correct, but might make "navigation" incorrect
just a hunch

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
enigmasolutionsAuthor Commented:
Thanks TheRealLoki,

Next time it happens I will inspect the PAS file.  I guess after 10 years of developing this one application some funny line terminators could have snuck in.

BUT, it is strange that the same PAS file behaves OK after a Close All / Delphi restart.

FYI it happened again on a differen PAS file yesterday.  It seems to happen after more editing.  This is day 3 of working in D2009, so it might be a few days before I can get some better info on this.

QUESTION: Does Delphi just search the PAS file or does it use the DCU with pointers to line numbers where definitios are declared?  I suspect the later.  I mean Mad Exceptions can provide line numbers where errors occur without the PAS file.  And if this is the case then somehow these pointers are getting stuffed up.

HAS ANYONE ELSE COME ACCROSS THIS?  
If so please drop in a line.
enigmasolutionsAuthor Commented:
Not really the right answer - but need to close this question + thanks for the response.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.