looking for opensource chat server for inhouse

I run Linux on my desktop and my wife runs WinXP.  We have been using skype chat to communicate between the office and house.  I work in my office in a separate building from the house.

Skype has been acting flaky--plus I don't like the company for a variety of reasons.

I would like to set up a simple in-house chat system and would appreciate any suggestions.  

Criteria:

1. Must be able to chat using Linux or MS.
2. Must be easy to set up.
3. Would prefer to not leave the local LAN, as in proprietary servers.

Thanks,
Frank
ibanjaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph DalyCommented:
We used to run openfire chat at my work.
http://www.igniterealtime.org/projects/openfire/

Very easy to set up and run with a lot of cool features. The chat client we used was their spark client
http://www.igniterealtime.org/projects/spark/index.jsp

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ibanjaAuthor Commented:
Thanks xxdcmast--checking that out.
0
Joseph DalyCommented:
This was very easy to set up. I think I had it up and running within an hour and after a little bit of reading was able to tie it into our active directory for LDAP authentication in about another hour. If you have any questions please let me know.
0
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

ibanjaAuthor Commented:
I have installed it on a remote computer and can't get access.

I have tried > 

https://hostname:9091
https://hostname:9090
http://hostname:9091
http://hostname:9090

Do you knoe if I have to change something?  The service is started.
0
naveencnairCommented:
Can you try speek-freely. It is a GNU GPL, I was using it long back. Website to download
http://speak-freely.sourceforge.net/

Setup is very easy and only UDP ports 2074 or 2075 needs to be allowed in the firewall, if any.
0
ibanjaAuthor Commented:
Thanks naveencnair,

I should have mentioned., my main use is the typing IM chat, not the voice.

That said, This still might be helpful for intercom usage--checking it out.

0
ibanjaAuthor Commented:
speak-freely had dependency issues and wouldn't install.  It is about 6 years old, so that could well be the problem.  
0
PBOICommented:
When you are trying to load the admin console, are you attempting to open it on the computer you installed it on or from a remote computer?

Instead of using the hostname, try using the IP itself.  You may have a dns issue.
0
PBOICommented:
Read this thread:  http://www.igniterealtime.org/community/thread/40510

This seemed portion caught my eye:  
This is probably a bug, affects linux version 3.6.4 too. You have to edit openfire.xml file (don't know where it is on windows, probably inside openfire/conf dir) and add text marked with red:

<!-- root element, all properties must be under this element -->
<jive>
  <admin>
    <authorizedUsernames>admin</authorizedUsernames>
  </admin>
   <adminConsole>
    <!-- Disable either port by setting the value to -1 -->
    <port>9090</port>
    <securePort>9091</securePort>
  </adminConsole>

 

Then restart openfire and you should login as admin with your password (password is admin if setup was skipped).
0
PBOICommented:
Also when you say you can't get access, please elaborate.  Do you mean you are getting an error like page cannot be displayed or are you getting the admin console but unable to login?  

Did you install it on a linux system or a Microsoft system?
0
ibanjaAuthor Commented:
Thanks PBOI,

I am getting a "could not connect to host 192.168.0.160 (port 9091)" error.

The OS is CentOS4.  It is a remote box.  I have the firewall (on my tomato router) set to forward that port--though I wouldn't think that matters from inside the LAN.  Also, I can access the same computer from LAN or WAN side via SSl port 443 (port 80 is intentionally not used).  In other words the web server is up and running fine.  

I have tried IP address and hostname.

openfire is running:

$ sudo /etc/init.d/openfire status
Password:
openfire is running

I don't think it's a firewall issue.

# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  anywhere             anywhere

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain RH-Firewall-1-INPUT (2 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
ACCEPT     icmp --  anywhere             anywhere            icmp any
ACCEPT     ipv6-crypt--  anywhere             anywhere
ACCEPT     ipv6-auth--  anywhere             anywhere
ACCEPT     udp  --  anywhere             224.0.0.251         udp dpt:5353
ACCEPT     udp  --  anywhere             anywhere            udp dpt:ipp
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:http
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:https
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited


Thanks
0
PBOICommented:
You are moving well outside my comfort zone.  My linux knowledge is poor.  I would suggest you open a new topic with OpenFire installed on CentOS to attract experts that have that experience or go to the forum I've shown you.

Good luck though.  Once you get this running, I hope you'll find it worth the effort.  I inherited my installation in a MS 2003 environment, and it's been trouble free.
0
ibanjaAuthor Commented:
Well thanks for your input--much appreciated.  I did change the /opt/openfire/conf/openfire.xml file.

I am wondering if the listening setting needs changing--looking for syntax.

# cat /opt/openfire/conf/openfire.xml
<?xml version="1.0" encoding="UTF-8"?>
<!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>

    Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive>
        <admin>
                <authorizedUsernames>admin</authorizedUsernames>
        </admin>
    <adminConsole>
        <!-- Disable either port by setting the value to -1 -->
        <port>-1</port>
        <securePort>9091</securePort>
    </adminConsole>

    <locale>en</locale>

    <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->
    <!--
    <network>
        <interface></interface>
    </network>
    -->
</jive>
0
ibanjaAuthor Commented:
This is not abandoned.  Still working on a solution.
0
ibanjaAuthor Commented:
OK... that took me a while to get set up... :)

Openfire worked, although the Linux client  (Spark) isn't working--doesn't show up in system tray.  I will post a question about that.  

Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Chat / IM

From novice to tech pro — start learning today.