Why does my Konqueror browser not work on Experts-Exchange?

If I, supposedly, have a standards compliant browser, why won't it work on experts-exchange?

Problems include slooooooow loading of pages, and buttons that don't work, or features that aren't available or even seen.

Settings:

I used to use the default browser ID which is "Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.10 (like Gecko)".  I also had "Add operating system name" checked.

Because I experienced problems on other sites I started by unchecking "Add operating system name".  That helped, but I found that not sending any browser identification worked even better on the sites I was having problems with. So my settings now are "don't send any browser ID".

I'm thinking bad programming, such as asking if this is an MS browser rather than does this JS capability exist is the culprit, but would like to know for sure--very annoying.

Thanks,
Frank
ibanjaAsked:
Who is Participating?
 
torimarConnect With a Mentor Commented:
Personally, I've *never* used Internet Explorer, so I have more than 15 years of experience with non-MS browsers (Opera mainly, plus Firefox), and all the issues this could cause when websites are coded with IE in mind. I can tell you that these problems have become more and more rare over the years, and they certainly do not exist here on Experts-Exchange.

In the case of Konqueror, I'd suppose the "bad programming", if there is any, to be rather on the side of Konqueror itself. It certainly cannot be considered a full-fledged web browser that could compete with the big four or five. If you encounter problems with advanced JS/CSS, then chances are high that Konqueror simply doesn't support them well.

As to the extremely slow loading of pages, I also encountered that on several Linux KDE distros right after installation. At one time I realized that it most frequently comes paired with Ipv6. Since this technique isn't really used yet, you might want to consider disabling support for it on your system. That really speeds Konqueror up quite a bit.
0
 
ibanjaAuthor Commented:
Thanks torimar,

According to the documentation, Konqueror is "standards compliant."  Turning off ID has improved usability, that's why I think it is a website issue in many cases.

It's still not as fast as I'd like but better with ipv6 disabled.  That most likely is a KDE issue.  

For any who need to know, I have listed the steps I took here: http://www.nixish.com/wiki/doku.php?id=kde_konqueror_slow

I don't know if this is the best way to do this, but it's what I gleaned from searching around "how to disable ipv6 in Kubuntu".
0
 
ibanjaAuthor Commented:
Thanks forimar.  That helped some, with the speed aspects.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.