SFC /SCANNOW not working - regarding impersonation level

I have a Windows Server 2003 Service Pack 2 machine that I would like to run the System File Checker because I've been experiencing some minor issues and would like to do a check of the system files but when I try to do a check of the system files using SFC I get the following error message - Specific Error Code 0x00000542 (Either a required impersonation level was not provided or the provided impersonation level is invalid.) I have attempted to fix the impersonation level at the DCOM snap in but that did not make any difference.  Has anyone ever run into this before?
ITIExperts1Asked:
Who is Participating?
 
ITIExperts1Author Commented:
Closed
0
 
gemartiCommented:
I am not sure if this is the problem but if you check  the Group Policy Editor under Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment  "Impersonate a Client After Authentication" Properties on the local settings tab there should be at least the Administrator's group and SERVICE; you can can other accounts for services requiring different groups or permissions.
0
 
gemartiCommented:
BTW if you make changes to this policy you must restart the machine; I forgot to mention this...
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Davis McCarnOwnerCommented:
Or we can use an old NT trick.....
Login as Administrator
Do Start -> Run -> CMD<enter>
In the CMD Window, type AT 11:15 /INTERACTIVE CMD.EXE<enter> (the time is 24 hour and choose 1 or two minutes in the future when you type it)
At the time you specified, a new CMD window will appear with a huge bonus; it will be running as the SVCHOST account which is above Administrators.
Try running the SFC /SCANNOW in it.
0
 
Jason WatkinsIT Project LeaderCommented:
Hello,

Perhaps try changing the Default Domain Policy's "Impersonate a
client after authentication" setting to NOT DEFINED and reboot.
0
 
ITIExperts1Author Commented:
Tried all three of these solutions with the same end result, no luck.
0
 
Davis McCarnOwnerCommented:
Are you trying to do this remotely or at the server?
0
 
ITIExperts1Author Commented:
Remotely
0
 
Davis McCarnOwnerCommented:
I think you are going to have to do it at the console.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.