How to fix apache error: Directory index forbidden by Options directive?

I setup a website on a server (Fedora release 7;  Apache/2.2.8). I can access all of the pages on the site, however, when I run a script that writes a new html page, the script runs endlessly (i.e. browser says "waiting for mysite.com..." and I see this entry in the log file:

[Tue Apr 27 09:51:51 2010] [error] [client 10.5.96.9] Directory index forbidden by Options directive: /var/www/html/sites/mysite/trunk/files/

I searched experts-exchange and have tried the following recommendations in other posts:
* Disabled SELinux
* Confirmed there are no .htaccess files in /mysite/
* I am using this in my http.conf file: Options +Includes +FollowSymlinks +Indexes
* I restarted Apache

...with no luck.

FYI: this is working on a development server with the exact same php.ini and http.conf files.

Any ideas?
bearclaws75Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lloydswayzeCommented:
If you are trying to create a new html file on the website, it may be a permissions issue.
The message sounds more like you may be trying to reference a directory of files, which may  be locked down.  For instance, if you ask for http://website.com/subdir/filename.html the file will be displayed, but if you ask for http://website.com/subdir/  you may be requesting the list of files in the directory if it isn't set to default to a specific page (like index.html, or default.html).  Its not necessarily a good thing to allow access to directories, especially if webcrawlers or the public shouldn't see them.  So there may be a directive set up to prevent it.  If you want to see the directory you can create a php file to dislay it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bearclaws75Author Commented:
It was a permission error (!). Thanks for the reminder :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.