How do I check App Pool, Security, Execute Permissions in IIS 7?

Based on an earlier issue, I need to check the following:
Vroot in IIS                  Properties  
ClientWebService       Directory: %ProgramFiles%Update Services\WebServices\ClientWebService
                                    Application Pool: WsusPool
                                    Security: Anonymous Access Enabled.
                                     Execute Permissions: Scripts Only

Where do I go to accomplish this?
keithmendezAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brad HoweDevOps ManagerCommented:
Hi,

To start IIS Manager from the Run dialog box
1.On the Start menu, click All Programs, click Accessories, and then click Run.
2.In the Open box, type inetmgr and then click OK.

Now for your verification.

1. On the left pane, you will see a box called Connections. Browse to the following.
    SERVERNAME | Sites | Default Web Site (Or the website that has ClientWebService).

2. Right click on ClientWebService -> Click "Manage Application" -> Click "Avanced Settings"
    Application Pool [...] is the default pool for this webapp

3. In the /ClientWebServices feature window in the center -> Click "Authentication".
    This will tell you is anaonymous is enabled.

4.  Click SERVERNAME | Application Pools | WsusPool. In the Feature window -> Right click on WsusPool and    
     open advanced settings.This is your appPool settings.

5. Script Execution is handled by "Handler Mappings", Simply click on the ClientWebService and in the feature
    window you will see this link. This was changed from the basic IIS5/6 where an IIS application could execute
    permissions to None (read), Scripts only (scripting engine, and Scripts and Executable (executable dll, exe, etc
    files).  The value of those settings were kept using AccessFlags in the metabase key, this has changed in IIS
    7.0, the metabase key is depreciated.


Cheers,
Hades666
     
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
keithmendezAuthor Commented:
Where the instructions say Scripts only, I go to that location and there are 3 boxes.  Read, Scripts, and below Scripts is Execute.  I assume the instructions mean Scripts and Execute boxes are checked?
0
Brad HoweDevOps ManagerCommented:
Right from the IIS Manual.

Select one of the options on this tab to configure the access that this handler requires to run in a virtual directory. This setting (together with the feature's access policy that is set on the Edit Feature Permissions dialog box) determines whether a handler can run.

 Important  
 Make sure that the required access setting for a handler is correct or else it may be possible for the handler to run unintentionally. For example, if you change the handler's required access from Execute to Read for ISAPI-dll handler, ISAPI extensions will be able to run even if only Read is enabled in the feature's access policy.
 

Select one of the following options:

None: The handler will run even when no access policy options are enabled.
Read: The handler will run when Read is enabled in the access policy.
Write: The handler will run when Write is enabled in the access policy.
Script: The handler will run when Scripts is enabled in the access policy. This is the default selection.
Execute: The handler will run when Execute is enabled in the access policy.

0
Brad HoweDevOps ManagerCommented:
By your appPool definition, did you read this.

http://technet.microsoft.com/en-us/library/cc720452(WS.10).aspx

Cheers,
Hades666
0
keithmendezAuthor Commented:
Actually, no...I just looked thru my WSUS 3.0 documentation and don't see it in there, either.  I'll take a closer look at it, thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.