JFolder::create: Could not create directory

I have recently retored my joomla site using akeeba backup.  The site is up and works fine.  The problem I am experiencing is that when I try to install virtumart I get the following error:

JFolder::create: Could not create directory
Component Install: Failed to create directory.: "C:\inetpub\wwwroot\Intergroup\components\com_virtuemart"

I think this will be true for any componet I try to install.  Are there some permissions I need to change?  
rwh041Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amanda WatsonWeb DeveloperCommented:
You may need to change the owner of the folders to the user of the apache server.

or

Change CHMOD to 777 for /administration/components/
But don't forget to CHMOD 777 to /tmp aswell

Better solution  is to change the owner of the file to the apache owner, and then you don't need to set your permissions to 777.

As far as I know the best solution for this is to contact your webhost and request an ownership transfer for all maps and files to the FTP user you use.

0
rwh041Author Commented:
Thank you for the response.  I am using IIS7 on Server 2008.  I am not sure which owner change/give permissions to?  
0
Amanda WatsonWeb DeveloperCommented:
I am not sure with your set up.
All I know is when you look at the owner in FTP you see  that the owner/group would be shown there.
When you installed joomla all the files would have been assigned to a owner/group.

This needs to be the same so you can load up components.

Also something else you could try before all of this would be to load up your component by FTP.

Do this rather than loading if via the browsers.  The owner/group could be changing simply because of this.  I have encountered this before with a particular server and this solved the problem for me
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

rwh041Author Commented:
I am not using FTP on the server.  I logged into the server and checked the permissions  for the folder that contains the joomla web.  The joomla web is located in C:\inetpub\wwwroot\Intergroup.  There is a user listed in the permissions of the wwwroot called "Creator Owner"..This user has no permissions assigned.  I tried to give the Creator Owner full control to see if that is the problem but for some reason the permissons never stick.  Creator Owner reverts back to no permissions period.  
0
Amanda WatsonWeb DeveloperCommented:
Well can you change the folder permissions to chmod 777 as mentioned earlier?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwh041Author Commented:
not using apache.  im using iis7 on a 2008 server.  
0
Amanda WatsonWeb DeveloperCommented:
As I said I am not familiar with Microsoft Servers, only Linux

try
changing temp directory from "/tmp" to "tmp"

and perhaps you could read up this forum http://forum.joomla.org/viewtopic.php?p=1284769  there are some users there that are using IIS servers
0
rwh041Author Commented:
Ok.  Thanks.
0
conticreativeCommented:
Is the FTP layer on in the Joomla site? If it is, turn it off.
I know the error say "Cannot create directory" but sometimes it says that because it can't find the right error.
Sometimes permissions prevent you from editing the configuration file (configuration.php). In that case go to the file itself and change this string:
var $ftp_enable = '1';
to
var $ftp_enable = '0';

In the administration it's in the global preferences > System tab > FTP Settings

Another reason could be a timeout issue. Make sure your server timeout is set a bit longer.

Yet another thing to try would be to install from a URL. Upload VM to a folder than give Joomla the http:// path to the location (with the name of the installation file) and see what it does.

Last comment: I know this is not helpful right now, but Joomla is really a lot happier on a Apache server. If possible at all move the site to an apache server, possibly with PhpSuExec turned on and Cpanel.
Those are the best servers for Joomla and make your life much simpler.



0
rwh041Author Commented:
Ok.  Going back to the permission thing that snowball mentioned I found that giving the IUSR account in IIs7 permission to list folder contenets and write allowed me to  install the packages.  I think I will be putting this on an apache server. Is there a set of instructions for migrating joomla from IIS7 to APACHE?
0
rwh041Author Commented:
Thanks
0
conticreativeCommented:
Migrating Joomla to Apache from IIS is not that different from launching a site from a local build to a live one or from moving a site from one server to another.

You basically meed to do a databse dump. However it is set up on your server you need to export the entire databse.

Next you need to take all the files in your Joomla site and zip them up (if you can) or FTP them to your local computer.

Once you have the files and the DB locally you can do the same process in reverse to upload them to the Apache server.

If you get a hosting account with Cpanel it makes it a lot easier as you can upload all the files in a single ZIP file into the folder you want to deploy Joomla from and extract.

Next use the control panel to create a database, a new user and then assign the user to the DB.
Go to PhpMyAdmin and "import" the database to PMA.

Now you have the very last thing to do: Edit your configuration.php file to reflect the location of the "tmp" and "logs" folders and change the DB user, server, DB name and Password.

In this respect, if I can give you a neat trick, it helps to install a Virging Joomla site you can use as reference for the configuration.php variables and paths.

Otherwise, when you are ready, post the kind of server you got (especially the king of Panel) and I can post them for you here.

Often the path looks like this:

home/[username]/public_html/

But different servers can use different names like home/[user]/htdocs/
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Joomla

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.