Kernel error

I have an error as given below :
but i could not find any solution for this. Every time when my free ram gets under 2-3 gb it is getting down so fast and when it reach to 400 mb free it gives this error without using any swap memory,

Very strangely this is the same error that i see with the same harwdares, and in all the google i have found only this :D

how this happens, i could not understand is this a chance to have the same machine with the given example
Modules linked in: ipt_REDIRECT xt_owner xt_conntrack iptable_mangle nf_conntrack_ftp ipt_LOG xt_limit xt_multiport iptable_nat nf_nat autofs4 nf_conntrack_netbios_ns ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6table_filter ip6_tables x_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table loop dm_mirror dm_multipath scsi_dh video output sbs sbshc battery acpi_memhotplug ac lp snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_seq_dummy snd_seq_oss sr_mod snd_seq_midi_event snd_seq snd_seq_device sg snd_pcm_oss snd_mixer_oss cdrom snd_pcm snd_timer snd soundcore rtc_cmos rtc_core parport_pc parport serio_raw button floppy i2c_i801 rtc_lib snd_page_alloc shpchp tpm_infineon pcspkr i2c_core e1000e dm_region_hash dm_log dm_mod sata_via sata_sis pata_sis sata_sil sata_nv megaraid_sas ata_piix ahci libata 3w_xxxx 3w_9xxx sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Pid: 4243, comm: tar Not tainted 2.6.30 #1 ESPRIMO P5925 
RIP: 0010:[<ffffffff802a97ce>] [<ffffffff802a97ce>] fput+0x0/0x12
RSP: 0018:ffff8801e5411db0 EFLAGS: 00010282
RAX: 0000000000000029 RBX: ffff8801dd45a2a0 RCX: 0000000000000000
RDX: ffff880028064000 RSI: 0000000000000046 RDI: ffffffffffffffb5
RBP: ffff88022bd0f7b8 R08: ffff8801e5411e68 R09: ffff880225cf5540
R10: ffff88022b030110 R11: ffffffff80312e03 R12: ffffffffffffffb5
R13: ffff8801e5411e68 R14: ffff8801e5411e00 R15: ffff88022bd0f7e0
FS: 00007fda58e8f710(0000) GS:ffff880028064000(0000) knlGS:0000000000000000
CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: ffffffffffffffe5 CR3: 00000001edc68000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process tar (pid: 4243, threadinfo ffff8801e5410000, task ffff8802269d2300)
Stack:
ffffffff80331706 ffff8801dd409a48 ffff8801dd409a48 0000000000000000
0000000000008001 0000000000000004 ffff8801e5411e68 ffff8801dd45a200
ffffffff802b0ce0 ffff88022bd16bc0 0000000000000000 ffff8801e5411e68
Call Trace:
[<ffffffff80331706>] ? ima_path_check+0x188/0x1b3
[<ffffffff802b0ce0>] ? may_open+0xbf/0x261
[<ffffffff802b3308>] ? do_filp_open+0x48c/0x88c
[<ffffffff802ba958>] ? alloc_fd+0x69/0x10c
[<ffffffff802a6da0>] ? do_sys_open+0x4b/0xc8
[<ffffffff8020b96b>] ? system_call_fastpath+0x16/0x1b
Code: 48 89 d8 5b 5d 41 5c 41 5d 41 5e c3 48 8b 05 d2 1a 52 00 41 ba 01 00 00 00 48 85 c0 49 0f 48 c2 89 05 b7 07 3b 00 e9 49 55 f9 ff <f0> 48 ff 4f 30 0f 94 c0 84 c0 74 05 e9 14 fc ff ff c3 55 48 89 
BUG: unable to handle kernel paging request at ffffffffffffffe5
IP: [<ffffffff802a97ce>] fput+0x0/0x12
PGD 203067 PUD 204067 PMD 0 
Oops: 0002 [#2] SMP 
last sysfs file: /sys/devices/system/cpu/cpu3/cache/index2/shared_cpu_map

Open in new window

LVL 1
CahitEyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joolsSenior Systems AdministratorCommented:
you need to say what kernel version you are using, perhaps what was running one the server at the time...

It could be a hardware fault or a kernel bug that a yum update would fix.
CahitEyAuthor Commented:
2.6.30
#1 SMP Tue Sep 8 10:46:11 CEST 2009

i had tryed for yum update :(
joolsSenior Systems AdministratorCommented:
Centos is currently on 2.6.18 where did you get 2.6.30 from. What Centos are you running?

cat /etc/redhat-release
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

CahitEyAuthor Commented:
CentOS release 5.4 (Final)
joolsSenior Systems AdministratorCommented:
I'm on Centos 5.4 but my kernel is 2.6.18-128 Have you installed a kernel from kernel.org?

Where did 2.6.30 come from, that could be causing your problems. You should be using the stock kernels with Centos.
CahitEyAuthor Commented:
no this is installed my datacenter's rescue system it is standart for all servers
joolsSenior Systems AdministratorCommented:
what do you mean by your datacenters rescue system?

If you're not using the standard kernels then you could get strange results. I would have to suggest you use the standard kernels.
CahitEyAuthor Commented:
you misunderstood me
My datacenter give me a rescue system and it install this to all server's in the datacenter this version
if i install over rescue it will be with kernel 2.30 like all the other servers in there
joolsSenior Systems AdministratorCommented:
I guess I'm not following this at all.

You say you're usiing Centos 5.4 but Centos 5.4 uses a 2.6.18 kernel and you say your kernel is 2.6.30 but this is your "rescue system".

Now if you install over the rescue system it will be with kernel 2.30.

I'm afraid I can help but be confused.

You'll need to explain what is going on any why you are not using the stock kernel for your Centos 5.4 install.
CahitEyAuthor Commented:
because datacenter advice to use this image ,
also we have checkd nearly all services error logs. but there was no problem with any of them for ex. when i face with this problem today there was only 68 active client on apache and one time i had faced with this there were 2000+ clilents but any of this my free ram is not under 3Gb
when it come to 3gb free memory it directly counts down to 400 and locks the server.
cpu usage is also seems normal.
svsCommented:
Your bug looks awfully like this one:

http://lkml.indiana.edu/hypermail/linux/kernel/0906.0/02761.html

They refer to 2.6.30-rc8 (pre-release kernel version).  Ask your datacenter about it.
CahitEyAuthor Commented:
This is also plesk's report :

 --------------------- Kernel Begin ------------------------ 

 
 WARNING:  General Protection Faults in these executables
    links :  1 Time(s)
 
 WARNING:  Kernel Errors Present
    EXT3-fs error (device sda1): e ...:  7 Time(s)

Open in new window

svsCommented:
I'd worry about EXT3-fs error.  Search system logs for exact error message.
Duncan RoeSoftware DeveloperCommented:
I would go to single-user mode, ensure /dev/sda1 is mounted read-only and run fsck -f on it.
This should tell you whether the EXT3 errors actually cause damage, or are only errors in reading (possibly associated with the kernel bug you appear to have encountered)
HappyCactusCommented:
It could be a ram fault - can you try to change some ram module?
Duncan RoeSoftware DeveloperCommented:
You could also test your RAM by running memtest86, available from http://www.memtest86.com

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CahitEyAuthor Commented:
Thanks everybody for help it was encountered of a ram issue finally solved
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.