• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1122
  • Last Modified:

Centos 5.3 on Xen 5.5 - Trying to get into Gnome

Hello,
I cannot get out of the shell into gnome, I tried running the command startx but get the message below:


[root@Blackbox1 mnt]# startx
xauth:  creating new authority file /root/.serverauth.2806


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux Blackbox1 2.6.18-128.el5xen #1 SMP Wed Jan 21 11:55:02 EST 2009 i686
Build Date: 21 January 2009
Build ID: xorg-x11-server 1.1.1-48.52.el5
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 27 11:13:11 2010
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 4 of section (null) in file /etc/X11/xorg.conf
"using" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
0
mancoi
Asked:
mancoi
  • 11
  • 10
1 Solution
 
muffCommented:
Can you post the /etc/X11/xorg.conf file?  From the error message you simply have a syntax error where the word "using" appears where it shouldn't.

Line 4.  It isn't in a section so I think it was typed in accidentally.
0
 
mancoiAuthor Commented:
This is exactly how my xorg.conf file looks:



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool,
using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual
page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades
*only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically
updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf
>/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg
Section "Files" FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc" FontPath
"/usr/lib/X11/fonts/cyrillic" FontPath
"/usr/lib/X11/fonts/100dpi/:unscaled" FontPath
"/usr/lib/X11/fonts/75dpi/:unscaled" FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID" FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" FontPath
"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID" EndSection Section
"Module" Load "bitmap" Load "dbe" Load "ddc" Load "dri" Load "extmod"
Load "freetype" Load "glx" Load "int10" Load "record" Load "type1" Load
"vbe" EndSection Section "InputDevice" Identifier "Generic Keyboard"
Driver "keyboard" Option "CoreKeyboard" Option "XkbRules" "xorg" Option
"XkbModel" "pc105" Option "XkbLayout" "gb" EndSection Section
"InputDevice" Identifier "Configured Mouse" Driver "mouse" Option
"CorePointer" Option "Device" "/dev/input/mice" Option "Protocol"
"ImPS/2" Option "Emulate3Buttons" "true" Option "ZAxisMapping" "4 5"
EndSection Section "Device" Identifier "ATI Technologies, Inc. Radeon
X850 XT PE (R480)" Driver "ati" BusID "PCI:5:0:0" EndSection Section
"Monitor" Identifier "Generic Monitor" Option "DPMS" HorizSync 30-65
VertRefresh 50-75 EndSection Section "Screen" Identifier "Default
Screen" Device "ATI Technologies, Inc. Radeon X850 XT PE (R480)" Monitor
"Generic Monitor" DefaultDepth 24 SubSection "Display" Depth 1 Modes
"1280x1024" "1024x768" "800x600" "640x480" EndSubSection SubSection
"Display" Depth 4 Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection SubSection "Display" Depth 8 Modes "1280x1024" "1024x768"
"800x600" "640x480" EndSubSection SubSection "Display" Depth 15 Modes
"1280x1024" "1024x768" "800x600" "640x480" EndSubSection SubSection
"Display" Depth 16 Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection SubSection "Display" Depth 24 Modes "1280x1024" "1024x768"
"800x600" "640x480" EndSubSection EndSection Section "ServerLayout"
Identifier "Default Layout" Screen "Default Screen" InputDevice "Generic
Keyboard" InputDevice "Configured Mouse" EndSection Section "DRI" Mode
0666
EndSection
0
 
mancoiAuthor Commented:
Yes the format of this file is all messed up.

What do you suggest, I do not know what should be commented and what should be on what line.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
muffCommented:
If you post it as an attachment, I'll format it and attach it back.
0
 
mancoiAuthor Commented:
Here is the file, thank-you
conf.txt
0
 
muffCommented:
Ooh.  What a mess!

Try this...
conf-better.txt
0
 
muffCommented:
Oh, and please don't edit using Windows notepad whatever you do.
0
 
mancoiAuthor Commented:
Thanks for the reformatting.

I still cannot start gnome.

I am getting this error:


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux Blackbox1 2.6.18-128.el5xen #1 SMP Wed Jan 21 11:55:02 EST 2009 i686
Build Date: 21 January 2009
Build ID: xorg-x11-server 1.1.1-48.52.el5
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 28 04:06:04 2010
(==) Using config file: "/etc/X11/xorg.conf"

(EE) No devices detected.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
0
 
muffCommented:
Ok, could you provide:

  lspci -nn

and a copy of /var/log/Xorg.0.log

0
 
mancoiAuthor Commented:
lspci -nn did not return anything.

My log file is attached
Xorg.0.log.txt
0
 
nithinprabhakarCommented:
Have you tried re-installing Gnome packages? I would have tried that if Gnome is not coming up.
0
 
mancoiAuthor Commented:
dont know how I can reinstall, but it looks like there is an issue with hardware?

Maybe I should run the Xen install tools? Do you think this could help?

I can get it into the CD drive, but have not idea how to run it from command line.
0
 
muffCommented:
Your config says you have an ATI graphics card, but you are running under Xen, which is why lspci isn't showing anything.

Xen will use a framebuffer as output for graphics, so can you provide

  ls /dev/fb*

I am guessing there will be an fb0 so the xorg.conf device section should be altered from:

Section "Device"
      Identifier "ATI Technologies, Inc. Radeon X850 XT PE (R480)"
      Driver "ati"
      BusID "PCI:5:0:0"
EndSection


to


Section "Device"
      Identifier "ATI Technologies, Inc. Radeon X850 XT PE (R480)"
      Driver "fbdev"
      Option "fbdev" "/dev/fb0"
EndSection
0
 
mancoiAuthor Commented:
ls/dev/fb* did not output anything

I made the chnage to the file and it did not make startx work.
0
 
muffCommented:
Can you provide the xen config file you use to launch the domu?  

0
 
muffCommented:
Also

  zcat /proc/config.gz | grep XEN

0
 
muffCommented:
Hang on a second - where are you expecting the gnome desktop to appear if this is a VM?  I have been assuming sdl / vnc.

Is that right?
0
 
mancoiAuthor Commented:
Yes I want the gnome desktop and I am running this Linux on a virtural machine (Xen server)
0
 
muffCommented:
Yes, but where is the desktop outputting to?  Can you provide the domu config file?
0
 
mancoiAuthor Commented:
where do i find the domu file?
0
 
muffCommented:
Not sure under Citrix xen server, but under vanilla Xen they are in /etc/xen

The question remains as to where the gnome desktop should be output to - if you set up the VM did you specify anything related to what graphics should be used?

With any X application, the output needs to go to an X Server.  Either on the machine itself, or on another machine.  Under Xen, if you want the VM machine itself to run the X Server, then it needs a graphics device to output the graphics to.  Xen can provide a graphics device via a virtual frame buffer, and this is either VNC or SDL based.  In both cases, a /dev/fb0 device is created, and the graphics output goes to this device.  With the VNC option, the frame buffer can be viewed with a VNC client.  With SDL the output goes to the X Server running on the Xen host, the Dom0.

The third option is to run an X server elsewhere, and output the graphics to it.  You do this with

  export DISPLAY=<ip address of X server>:0

If you subsequently run startx, it won't attempt to start the X server in the vm, it will instead output the graphics to the host specificed in the export command.

So to proceed, I'd need to know where you were intending to see the output.   Is the Xen server the same server you want to see the output on?  If so, look for an SDL option in the VM definition and enable it.  Then the changes made to the xorg.conf previously should work.
0
 
mancoiAuthor Commented:
No real answer, but thanks for sticking with me.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 11
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now