SharePoint 2007 Search only working on one site collection

I have multiple site collections (hosted under multiple websites) using the same search account
and SSP all on the same server. The scopes are setup to search all the sites. The only site I am able to pull results on
is the first site collection I setup. The results are only able to grab data from that site collection.
When I query on any of the other site collections I am not getting any data back at all.
(1) Can I search multiple site collections from any site collection.
(2) Why isn't search working on the other site collections even though I am only looking for data
in that site collection
LVL 1
mvozilaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bart-VandyckCommented:
Hi,

Have you checked that the missing Site Collection are included in the Content Source for the crawler?

Do yo see any errors in the Cral Log?

rgds,
mvozilaAuthor Commented:
The site collection is in the Content Source. However, I see the error message below for the collection where searching is not working. I am using the same search account for all the site collections. I checked and the search account is a dbo of all the content databases. I made it an sa to see if it made a difference and no luck. I didn't add any crawl rules.

Access is denied. Check that the Default Content Access Account has access to this content, or add a crawl rule to crawl this content. (The item was deleted because it was either not found or the crawler was denied access to it.)
mvozilaAuthor Commented:
I found this fix online and it worked.
http://svengillis.blogspot.com/2008/10/access-denied-when-crawling-moss.html


Disable the loopback check
Follow these steps: 1. Click Start, click Run, type regedit, and then click OK.
2. In Registry Editor, locate and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3. Right-click Lsa, point to New, and then click DWORD Value.
4. Type DisableLoopbackCheck, and then press ENTER.
5. Right-click DisableLoopbackCheck, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Quit Registry Editor, and then restart your computer.
 

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.