Error message applying Sql Server service pack 3

I am having a frustrating problem trying to apply a service pack to my sql sever.  This server is solely used for SSRS.  The database it draws it's data from is on another sql sever.  When I try to apply the service pack it fails  Here is the error:
Product                   : Reporting Services (MSSQLSERVER)
Product Version (Previous): 1399
Product Version (Final)   :
Status                    : Failure
Log File                  : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\RS9_Hotfix_KB955706_sqlrun_rs.msp.log
Error Number              : 29537
Error Description         : MSP Error: 29537  SQL Server Setup has encountered the following problem: [Microsoft][SQL Native Client][SQL Server]Could not locate entry in sysdatabases for database 'XXXX'. No entry found with that name. Make sure that the name is entered correctly.. To continue, correct the problem, and then run SQL Server Setup again.
---------------------------------------------------------------------------------------------------------------
After the failed install, I can't even open ny reports.  We I connect to the ssrs server I get the same error.

ppsditAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ronney_leslieCommented:
This is the only tested way to get your problem sorted.

http://blogs.msdn.com/emilianb/archive/2008/10/30/could-not-locate-entry-in-sysdatabases-for-database-x.aspx

If you need specific help let me know.

Ronney
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ppsditAuthor Commented:
Thanks Ronney Very Helpful.  I also found this aricle:
http://www.windows-tech.info/15/8f098953fd0b9068.php
Which explains why you can't use those default DB names.  I choose to simply rename my DB's before the upgrade and it worked for me.  Thank you so much for you help.  Can't believe Microsoft still does not have a fix for this.
0
ronney_leslieCommented:
My pleasure.

Ronney
0
ppsditAuthor Commented:
good news is I was able to run the upgrade.  I renamed my ppsdreprtservr DB to PPSD.  when it was finshed, I named it back to ppsdreportserver. The bad news is I was unable to succesfully  rename the tmbdb database.  Before I renamed it to match the reportserver database name, ppsdtempdb, I get error messages saying that it is looking for ppsdreportservertempdb.  If I rename it, my reports work but my subscriptions dont, the error says it is unable to find ppsdtempdb  I can't win.  in the end I copied the temp db so there are 2, named differently, ppsdtempdb and ppsdreportservertempdb.  everything "works" now but seems sloppyandconfusing.  any avice for how to clean up that mess?

thanks,
Jeff
0
mlmccCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.