ASA5510 & Linksys/Cisco SGE2000 VLAN

I am attempting to configure my ASA5510 for a simple VLAN using a Linksys/Cisco. I have another outside appliance and I am using the ASA a layer 3 device to pass traffic and for my VPN.
Here are my config files from the ASA and the SGE2000 switch but i am not able to get out via any of the vlans.

!
ASA Version 8.2(1)11
!
hostname
domain-name test.local
enable password
passwd
names
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 192.168.3.3 255.255.255.128
!
interface Ethernet0/1
 no nameif
 security-level 100
 no ip address
!
interface Ethernet0/1.25
 vlan 25
 nameif inside
 security-level 100
 ip address 192.168.25.1 255.255.255.0
!
interface Ethernet0/1.50
 vlan 50
 nameif fts
 security-level 49
 ip address 192.168.50.1 255.255.255.0
!
interface Ethernet0/2
 nameif dmz
 security-level 50
 ip address 192.168.30.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
dns server-group DefaultDNS
 domain-name egsnetwork.local
access-list NO_NAT extended permit ip 192.168.25.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list NO_NAT_DMZ extended permit ip 192.168.30.0 255.255.255.0 192.168.20.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu management 1500
mtu fts 1500
ip local pool VPN_POOL 192.168.20.2-192.168.20.254 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-623.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NO_NAT
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list NO_NAT_DMZ
"static (inside,dmz) 192.168.25.0 192.168.25.0 netmask 255.255.255.0 "
route outside 0.0.0.0 0.0.0.0 192.168.3.16 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set VPN esp-aes-256 esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map VPN 65000 set transform-set VPN
crypto map VPN 65000 ipsec-isakmp dynamic VPN
crypto map VPN interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal 10
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy EGS internal
group-policy EGS attributes
 dns-server value 192.168.25.10 192.168.25.9
 default-domain value egsnetwork.local
 address-pools value VPN_POOL
username
username
tunnel-group XXX type remote-access
tunnel-group XXX general-attributes
 default-group-policy XXX
tunnel-group XXX ipsec-attributes

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context

: end

interface ethernet g1
switchport mode trunk
exit
interface range ethernet g(2-4)
switchport mode general
exit
vlan database
"vlan 25,30,50"
exit
interface ethernet g2
switchport general allowed vlan add 25
exit
interface ethernet g3
switchport general allowed vlan add 30
exit
interface ethernet g4
switchport general allowed vlan add 50
exit
interface vlan 25
name Inside
exit
interface vlan 30
name DMZ
exit
interface vlan 50
name FTS
exit
interface range ethernet g(2-4)
switchport general acceptable-frame-type tagged-only
exit
interface vlan 1
ip address 192.168.3.104 255.255.255.128
exit
ip default-gateway 192.168.3.3
aaa authentication dot1x default none
sti-techAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bkepfordCommented:
If you mean out to the Iternet it doesn't look like you have setup NAT on the other VLANs.
0
bkepfordCommented:
err Internet
0
sti-techAuthor Commented:
Yes I mean out to the Internet. Can you explain what you mean by other VLANS?
0
bkepfordCommented:
Try ading

nat (fts) 1 0.0.0.0 0.0.0.0

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.