ntbackup problem

HI i have problem while taking ntbackup. i will run ntbackup command from run  then i select my microsoft exchange database then select the path for backup then start backup & then schedule then it will prompt me you must save the backup selection before you can schedule a backup do you want to save current selection now. if i say yes & give a name for selection then immidiately nebackup window disappeared & a log has been generated event id 1000 application error Faulting application ntbackup.exe, version 5.2.3790.3959, faulting module ntbackup.exe, version 5.2.3790.3959, fault address 0x00000000000bfe3c.

but at the same time if i run the backup immidiately instead of scheduling it compltes without any problem.
sudeep1242Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

luconstaCommented:
The user you are using to run backup has write right to the BKS file location? Usually: "C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Windows NT\NTBackup\data"?
This error you get in in wizard mode or advanced mode?
You can create "by hand" the selection from Job manu selecting "Save selections" or "Save selections as..."?
0
sudeep1242Author Commented:
i am taking backup using administrator account only. the error is in advance mode. when i hit schedule
button it auutomatcally prompt me to save selection yes or no but in both the condition either yes or no the ntbackup box disappeared & a event log 1000 is generated in application log.
0
luconstaCommented:
Try before hit "schedule" to select "Job" menu and manually save selection with "Save selections" or "Save selections as..." so the selection would be already saved when you hit the "start backup" button to schedule your backup to see if this way will still gave you the same error...
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

sudeep1242Author Commented:
i will use save selection manually, the save command complted successfully but again when i hit
schedule button my ntbackup window disappear & event log generated in application log, really frustrated with this issue.
0
luconstaCommented:
If you have all the updates available "in place" and still have this error I would recommend to try re-install ntbackup to see if there is any change - I have the same version as you have (I don't use it frequently because I have another backup system) but I have no problem - do you installed another backup system (or test some - because uninstalling the "other" one it may cause some troubles with the Microsoft's ntbackup.
0
sudeep1242Author Commented:
how do i re-install ntbackup ?
0
luconstaCommented:
I have found something but is related to Windows Server 2003 Small Business and I didn't have the chance to test it on Windows Server 2003 to see if is the same:
1. http://www.tech-archive.net/Archive/Windows/microsoft.public.windows.server.sbs/2008-10/msg00228.html
2. http://www.eggheadcafe.com/software/aspnet/32583019/nt-backup.aspx

If I'll have the time before you cand test it yourself I will get back with details...
0
sudeep1242Author Commented:
both of the url are not helpful for me even if i tried apart from exchange database, any other folder
to take backup, widow disappear & event log generated.
0
luconstaCommented:
Can you try to make a "test backup" with a simple selection - for example backup a single folder with a single file in it - just to see if the selection is causing this problem or is the ntbackup.exe itself.
Maybe if the selection is to "wide" is the fact that cause the crush... but will see after the test.
0
sudeep1242Author Commented:
if you see my previous post i already mention that i have tried by talking a single folder of just 5 mb
& try to schedule it but result was same unable to schedule the backup & window disappear. i think
their is a problem with ntbackup.exe. but this is also true that i am able to backup manually with
start immidiately.
0
luconstaCommented:
In this case maybe the problem is the Task Scheduler... do you have other tasks scheduled that work correctly?... can you schedule a task (for example tu run Calculator or open a text file, or just Notepad) to be shure tha Task Scheduler is working correctly?
0
luconstaCommented:
Meanwhile I can suggest 2 workarounds:

1. Use a script to schedule a backup cron job - see my last posted message with code from this subject: dows XP backup using Group Policy
The disadvantage of this sollution is that AT cron jobs cannot be "maintained" by Scheduled Tasks
2. Schedule a task for NTBACKUP.EXE command and then you can add the parameters like the ntbackup will do when you press the schedule button and the final command will look like this:
C:\WINDOWS\system32\ntbackup.exe backup "@ListFileForBackup.bks" /a /d "Description if needed" /v:no /r:no /rs:no /hc:off /m normal /j "BackupJobName" /l:s /f "LocationOfBackup.bkf"
0
sudeep1242Author Commented:
i dont have any task scheduler program other than windows to run. i dont know how to crate scripts.
is there any solution for windows scheduler not working.
0
luconstaCommented:
You mean you don't have the "Scheduled Tasks" in Control Panel?...
0
sudeep1242Author Commented:
ooh i am sorry i will never perform task schedulig using this metod, anyways i tried to schedule from scheduler task but it gives me an error the task could not be creatd access denied try usng the task page browse button to locate the application. i am login with administrato account only. even then after also qestionstill remains why ntbackup.exe generating error. is there any method to re-installed ntbackup.exe
0
luconstaCommented:
I recommended this method only as a "temporary workaround" and mostly to check if the Task Scheduler works as is supposed, because as I said before - the problem might NOT be the NTBACKUP but the Task Scheduler.

That's why I need to know if you can "schedule" something in Control Panel\Task Scheduler (not necessary the ntbackup) and if that "scheduled event" ran correctly.
0
sudeep1242Author Commented:
but while adding task it gives me the below error
the task could not be created access denied try usng the task page browse button to locate the application. i am login with administrator account only.
0
luconstaCommented:
In this case try to check the Task Scheduler service ig is it running - go to "run" menu and type "services.msc" - and verify if the service is in "running" state and also check that "startup type" to be on "Automatic"

Also verify the event log for error related to the task scheduler - you may find the problem easier.

As a last resort it seems that sometimes re-installig Internet Explorer (uninstall and reinstall after a reboot) it might solve the task scheduler error.
0
sudeep1242Author Commented:
still having the same issue
0
luconstaCommented:
I don't know how important is your server but I have another ideea that will require a FULL BACKUP of your server just in case something will go wrong: a windows repair install - but only if your server is NOT a domain controller!

This would mean the following steps:
1. Full backup (manual - you said manual backup is working)
2. Uninstall Internet Explorer 7/8
3. Boot from you Windows Server CD and after you select install and agree with EULA it should detect an existing installation and suggest a repair. (ATTENTION: you should select repair with no formatting or something else otherwise you'll have a fresh Windows Server install - and I don't think is wat you want)
4. Reinstall Internet Explorer and do all the updates necesary.

If still doesn't work after these steps I think the only option ramaining is a "fresh install" with all applications and services required for that server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sudeep1242Author Commented:
server is not a domain controller but re-installing os is not a good idea
0
sudeep1242Author Commented:
still having the same problem
0
luconstaCommented:
sudeep1242, thank you for the points but you should not give them especially your problem is NOT solved.

And I didn't recommendend the re-install as a "fresh install" only if the "repair install" will not work - and the "repair install" shouldn't be dangerour if the server is not a domain controller - a repair install should preserve all the settings except IE7 or 8 that's why is recommended to uninstall them first.

If still no change after that "repair" you could request deletion of your question with full refund because as the problem is not solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.