GPO shows in GPRESULT but is not being applied successfully

Hi everyone,

Bit of a strange one this.

I have built a simple MSI for installing a font.  I would like to roll out this font to all our PC’s using Group Policy.

I tested the MSI/GPO on a couple of test PC’s, which are located in a ‘test’ OU.  This ‘test’ OU is a sub group of our main group.  Everything worked perfectly on the test pc’s.

Now I want to roll out the GPO to all our PC’s so i linked it to the ‘top level’ OU, along with all our other GPO’s.

GPRESULT /R shows that the PC’s are detecting the GPO without problem.  The font however just does not install.

Any ideas why this would work in a ‘sub’ test group, but not in the main group?
stalbansschoolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike ThomasConsultantCommented:
There is no reason why it would not work, however is there anything different about the pc's you policy now applies to? different site? permissions? etc

Maybe you need to turn off fast logon so the pc's wait?
Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Muhammad KhanManager, ITCommented:
If the clients in question are on slower link.. you may need to re-check slow link threshold group policy  which is found here

Computer Configuration\Administrative Templates\System\Group Policy\Group Policy slow link detection
User Configuration\Administrative Templates\System\Group Policy\Group Policy Slow link detection

Software installation policies don't process if the client is detected to be at a slow link ...

If that's not the problem... make sure update MS Installer version is installed on every client machine..
0
Sean_D76Commented:
hmmm...

Just to get some clarity...

Is that MSI being Assigned or Published in the GPO?

In the GPO did you configure it under User Configuration or Computer Configuration?

On your test PCs did you login with an Administrator account to see if it worked?  Do your users under the main group typically have local admin rights?

Are you sure your not blocking Inheritance on any of the OU's which contain either your user's or PCs to which you wish to apply this object?  (i.e. blue exclamation point on folder).

Can you maybe post a sanitized GPRESULT /R and/or the Output of "Settings" tab of the GPO.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Sean_D76Commented:
One more... are any of your "main group" clients using Wireless to access the LAN?
0
stalbansschoolAuthor Commented:
The MSI is being Assigned.  What is the difference between assigned/published?

The GPO has been configured under Computer Configuration.  We are in a school environment so I dont want it to slow down the logons as many different users will use different pc's.

Users do not have Admin rights, on my test PC I tested with a non-admin account.

There are NO blue exclamation points on any of the folders

-------------------------------

I could fiddle about with 'slow link thresholds' etc but I dont wat to slow down logon times etc.  How will this slow down logon speeds?
0
stalbansschoolAuthor Commented:
no wireless...they are all wired
0
Mike ThomasConsultantCommented:
Assigned will just install, published will appear in add remove programs so users can choose to install it.

0
stalbansschoolAuthor Commented:
Ok, well it is assigned I want then (all my other MSI's have been assigned and its worked fine)

Ok, just been looking in the event veiwer on one of the pc's and noticed these (see attached)

It seems that It tries, but fails to install...and then it tries to remove it and fails!






error1.PNG
error2.PNG
0
Mike ThomasConsultantCommented:
Are the share and security permissions set correctly on the share holding the install files?
0
stalbansschoolAuthor Commented:
They are the same as all the other folders (containing my other MSI's) in that share location and they work fine.

I also know that it works for my test group and there is no reasons the permissions would be different for that

0
stalbansschoolAuthor Commented:
Ok, well i did as Mojotech said in the first reply and set:

Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

and added it as a GPO.  I then set the link order for this to make sure it was above my MSI install.

Then i did a gpupdate /force

No difference :(
0
stalbansschoolAuthor Commented:
In the end I gave up and used a GPO with a startup script to silently install the MSI

That worked fine.

...very odd though, thanks for your help
0
stalbansschoolAuthor Commented:
Helped me towards my solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.