Why is Activesync e-mail slow to reach iPhone on Exchange 2007?

We have iPhones connected to the Exchange 2007 server. Everything is working. In fact, Outlook, OWA, Outlook Anywhere, and Autodiscover are all working very well. But e-mail sent to the Exchange accounts arrives in Outlook pretty much instantly, and seems to take 15 to 20 minutes to reach iPhone, most of the time. I have looked for some optimization articles, and I mean to say optimization, as it never fails to arrive. I can't really find much on iPhone, specifically. But this does not seem like the AUTD experience. Maybe there is something I don't have tweaked right, and I could use some experienced suggestions for optimization in this area.  
It's Exchange 2007 SP2, with all the rollups, on Windows 2008 SP2, all updates.
Exchange is behind a SonicWall TZ 210.
iPhones are 3GS with probably not all the latest firmware but close... like, v.3.1x.
Thanks.
gs-rhoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cas KristCommented:
Perhaps it is a setting in the iPhone, how often and with what interval to check.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cas KristCommented:
Maybe this helps (found it in google), i don't know much about iPhone:
•Tap Settings on the iPhone's Home screen.
•Select Fetch New Data.
•Pick the desired mail checking interval for POP and IMAP accounts under Fetch.
•Choose Manual to disable automatic checking.
•Turn Push ON or OFF to enable or disable new messages in Exchange and MobileMe accounts appearing in iPhone Mail the moment you receive them.
•To disable automatic mail checking for individual accounts or make push accounts update only periodically instead of instantly:
•Tap Advanced.
•Go to the desired account.
•Choose Manual for no automatic updates.
•Pick Fetch to have iPhone Mail check for new messages on the schedule set before.
•Select Push to have new messages pushed to Exchange accounts.
•Press the Home button.
0
MegaNuk3Commented:
as caskrist says... make sure your IPhones have "Push" on for the exchange account

they are probably set to "fetch" every 15 minutes at the moment.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

MegaNuk3Commented:
Do you have AV software on the server? If so, which one?

If you have AV software on there then ensure this key is in place:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan
ProactiveScanning      REG_DWORD      1
0
gs-rhoAuthor Commented:
Actually, it was the "Push" function that was the issue. It's a little confusing ... on the first page, where it says "Fetch New Data", I had it set for Fetch, because I thought I had to have it on that and then set the advanced settings inside, beyond that... I had the Exchange account set for Push inside... however, it didn't take, until I set that first settings "Fetch New Data" = Push, and then specially set my IMAP accounts as Fetch. How random. At least, IMHO... or I'm tired... whatever.  Thanks for the help. It's running 'real-time' now.
0
gs-rhoAuthor Commented:
MegaNuk3, thanks for the suggestion of optimizing the antimalware software.
We are running Forefront Security for Exchange version 2010, on Exchange 2007 SP2 /rollup 4.
So, what does that registry setting do and how does it affect matters?
0
MegaNuk3Commented:
yet, it is a bit odd that the advanced tab does not override the first setting. IMAP accounts will never push so the iPhone will fetch them (it is best to define Fetch).

Have a look at this article:  http://support.microsoft.com/kb/827615/en-us
It doesn't mention the reg key, but says to contact your vendor. since you are using a MS product I wouldn't worry about the reg key.
0
gs-rhoAuthor Commented:
We are using Symantec Mail Security on another server... do you recommend the reg key there then? I am more familiar with Symantec Mail Security. We're just trying out Forefront, for the first time ... anyway, I'll check out the article. Thanks.
0
MegaNuk3Commented:
I have just re-read the article and it only applies to Exchange 2000/ Exchange 2003, so unless you are running one of those, I think you can ignore it completely.

I haven't see Exchange 2007/2010 with activesync issues (yet)
0
gs-rhoAuthor Commented:
Cool. Thanks for the update.
0
gs-rhoAuthor Commented:
Experts solutions took some more investigation but put me on the right track.
0
MegaNuk3Commented:
Thanks for the points
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.