solaris10; Why I am not able to see route for add-on nic subnet; why its not picking from rc2.d/Sxxnetworks; ?

Hi !

Though I have a route in /etc/rc2.d/S45routes ; I am not seeing it after reboot. The said route is for a new NIC with a different subnet. How to ensure I have this route after each reboot, with out having to run svcadm restart network/physical.

Can you direct me to some source where I know the sequence of network events while booitng ?

Thanks
rags_cdotAsked:
Who is Participating?
 
RowleyCommented:
We're just trying to get to the root of the issue here, and you never mentioned that the -p option wasn't working for you.

So.

When you add a static route with the -p option, do you see the entry in the routing table? Can you see the entry in /etc/inet/static_routes file? What does the routing-setup service show as?

svcs routing-setup

0
 
robocatCommented:

route -p add ...

makes a route persistent.
0
 
RowleyCommented:
...after release 6/06///or thereabouts.
:)
Otherwise, the rc script is still the way to go. Post back the rc script, permissions on the script, if you don't have the -p option
0
 
rags_cdotAuthor Commented:
Ofcourse I added with route -p add network gateway;
Even then I have to add after every reboot :(
0
 
rags_cdotAuthor Commented:
I am sorry for the delay, Your commands helped me to verify the routes. But the issue is related to my new external interfcae configuration, which is not correct. I did mistake while assigning ether address. I reset the interface settings and started afresh, it started working fine.
Thanks for your time and patience.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.