Active sync issues for a single user.

Cannot sync with exchange on John's phone.
To start the troubleshooting process, I reviewed all the ActiveSync settings that were configured on John's phone and found them all to be correct. Checking the server settings and John's account, all the settings are identical to the ones configured for Steve Puls. As a test, I tried configuring the ActiveSync settings on my iPhone for the administrator account to see if I could get that working properly and I was able to. With the Administrator account working properly, I modified the settings on the iPhone for John's account and ran into problems again.
Based on these results, I tried setting up the Administrator account on John's phone and had no issues doing so which indicates the problem is not based with the phone itself, but John's account.


The problem is not related to the phone at all, as I was able to setup the administrator@domain.edu account on John's phone successfully.

John's account does not work properly when setup on an iPhone either which further points to an account issues. All Active Directory settings and Exchange settings have been reviewed and no discrepencies have been found when compared to another working ActiveSync user.

Testing of the settings can be performed via iPhone remotely and when settings are working successfully on a test phone, all settings are already configured on John's phone
Only John is having this issue. He has the Samsung Jack. It has Windows Mobile 6.5 Standard. All other mobile users are fine.

Also, I am seeing http status code 409 in the event application logs for his account.
We are running Win2003 SBS w/ Exchange 2003 sp2. Any help is greatly appreciated!
pchristopher52Asked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Please have a read through my Exchange 2003 / Activesync article, ceck your IIS settings, run the tests and report back any errors:
http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Exchange-2003-Activesync-Connection-Problems-FAQ.html 
0
 
Shreedhar EtteCommented:
Hi,

- Exclude the C:\inetpub, C:\Windows\System32\inetsrv from the Anti-virus scanning.

- Also recycle your router once.

Hope this helps,
Shree
0
 
pchristopher52Author Commented:
Alan,
I read your active sync article. But nothing addresses specific account issues. Active sync is working for other users. But just one user I can't get it to work for.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
pchristopher52Author Commented:
Shreedhar,
Those dir are already excluded.
Thanks.
0
 
Shreedhar EtteCommented:
then have restarted the router
0
 
Alan HardistyCo-OwnerCommented:
Buried in my article is the following:
To resolve this (if you like things tidy), please open up Exchange System Manager, Global Settings, Mobile Services Properties, Device Security Button, Exceptions Button, then add your account to the exceptions list.
Please do this for the problem user and then if that works - I'll explain why!
 
0
 
pchristopher52Author Commented:
Shreedhar,
There is no need to restart the router as it is working for other users.
Alan,
In order to add him as an exception I need to select Enforce password on device. I don't wan't to check that box as it might break active sync for the users that it is working for.
Thanks.
0
 
Alan HardistyCo-OwnerCommented:
If you don't enforce a password on the devices - you will not be able to remotely wipe them if they get lost / stolen, which is a major issue for your security.
I would recommend setting the password requirement, which will then ask existing users to add a PIN.
Alternative solution, and the explanation is to run Mobile Admin on the server, find the problem user and delete old Activesync pairings that are lurking (or delete all pairings and then setup the iPhone again).
0
 
pchristopher52Author Commented:
I saw another posting on ee as a possible solution:

http://sbs.seandaniel.com/2006/02/sync-errors-from-mobile-devices-in.html

But I don't know how to remove the inbox from the server sync schedule. Does anyone know how to do that?
Thanks.
0
 
Alan HardistyCo-OwnerCommented:
What type of phone are you trying to sync?
0
 
pchristopher52Author Commented:
A Samsung Jack.
0
 
Alan HardistyCo-OwnerCommented:
Assuming it is a Windows Mobile phone there is no way that I know of to deselect the Inbox as this is one of the default folders that gets synched without choice.
0
 
MegaNuk3Commented:
Just to confirm, if you put John's credentials in www.testexchangeconnectivity.com for the ActiveSync test does it work or fail?
0
 
pchristopher52Author Commented:
I created a new user and that user was not able to active sync. So it seems like any new user being created cannot active sync.
0
 
MegaNuk3Commented:
can you post the result of the www.testexchangeconnectivity.com test? alter any details with mspaint if you want or notepad.

Did the test user have at least 1 item in their inbox?
0
 
pchristopher52Author Commented:
The user had 3 emails in their inbox. I will post the result from the test site.
0
 
pchristopher52Author Commented:
Here are the results from testexchangeconnectivity.com:



Testing Exchange ActiveSync  
  Exchange ActiveSync test Failed
   Test Steps
   Attempting AutoDiscover and Exchange ActiveSync Test (if requested)
  Failed to test AutoDiscover for Exchange ActiveSync  
   Test Steps
   Attempting each method of contacting the AutoDiscover Service
  Failed to contact the AutoDiscover service successfully by any method
   Test Steps
   Attempting to test potential AutoDiscover URL https://.com/AutoDiscover/AutoDiscover.xml 
  Failed testing this potential AutoDiscover URL
   Test Steps
   Attempting to resolve the host name .com in DNS.
  Host successfully resolved
   Additional Details
  IP(s) returned:  
 
 Testing TCP Port 443 on host .com to ensure it is listening and open.
  The port was opened successfully.
 Testing SSL Certificate for validity.
  The SSL Certificate failed one or more certificate validation checks.
   Test Steps
   Validating certificate name
  Certificate name validation failed
   Tell me more about this issue and how to resolve it
   Additional Details
  Host name .com does not match any name found on the server certificate CN=www.webbuildersolution.com, OU=Thomson Professional, O=Thomson Corporation, L=Eagan, S=Minnesota, C=US, SERIALNUMBER=  
 
 
 
 
 
 Attempting to test potential AutoDiscover URL https://autodiscover..com/AutoDiscover/AutoDiscover.xml 
  Failed testing this potential AutoDiscover URL
   Test Steps
   Attempting to resolve the host name autodiscover..com in DNS.
  The Host could not be resolved.
   Tell me more about this issue and how to resolve it
   Additional Details
  Host autodiscover..com could not be resolved in DNS Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()
 
 
 
 
 Attempting to contact the AutoDiscover service using the HTTP redirect method.
  Failed to contact AutoDiscover using the HTTP Redirect method
   Test Steps
   Attempting to resolve the host name autodiscover..com in DNS.
  The Host could not be resolved.
   Tell me more about this issue and how to resolve it
   Additional Details
  Host autodiscover..com could not be resolved in DNS Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()
 
 
 
 
 Attempting to contact the AutoDiscover service using the DNS SRV redirect method.
  Failed to contact AutoDiscover using the DNS SRV redirect method.
   Test Steps
   Attempting to locate SRV record _autodiscover._tcp..com in DNS.
  Failed to find AutoDiscover SRV record in DNS.
   Tell me more about this issue and how to resolve it
 
 
 
 
 
 
 
 
0
 
MegaNuk3Commented:
OK, ignore the autodiscover test and use the "manually specify server settings" test and post me the result again please
0
 
pchristopher52Author Commented:
I change the testing from auto to manual and here are the results.

Testing Exchange ActiveSync  
  Exchange ActiveSync test Failed
   Test Steps
   Attempting to resolve the host name .com in DNS.
  Host successfully resolved
   Additional Details
  IP(s) returned:  
 
 Testing TCP Port 443 on host .com to ensure it is listening and open.
  The specified port is either blocked, not listening, or not producing the expected response.
   Tell me more about this issue and how to resolve it
   Additional Details
  A network error occurred while communicating with remote host
Exception Details:
Message: No connection could be made because the target machine actively refused it :443
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()

We are not using ssl so I don't know why it is listening on port 443.
 
 
 
 
0
 
MegaNuk3Commented:
OK, that test is not going to work for you at all then cause it uses SSL
0
 
MegaNuk3Commented:
OK, there is a free iPhone app called "AS Tester" you can download from itunes or from this website
https://store.accessmylan.com/main/promo-testtool

it will give lots of diagnostic information and allow you test with SSL off

Are you willing to try it?
0
 
pchristopher52Author Commented:
Sure, I'll give it a whirl.
0
 
pchristopher52Author Commented:
I downloaded and installed the app on my iphone. The results I got: ActiveSync is not available. Activesync detected, but access denied. HTTP 403 disabled for this user.

Activesync is enabled for this user. I doubled checked the user account.
0
 
MegaNuk3Commented:
try adding that account to the device exceptions list:
Open Exchange System Manager--> Global Settings-->Mobile Services-->Properties-->Device Security-->Exceptions--> then add the account to the exceptions list
0
 
pchristopher52Author Commented:
Mega...
In order to add him as an exception I need to select Enforce password on device. I don't wan't to check that box as it might break active sync for the users that it is working for.
Thanks.
0
 
Glen KnightCommented:
I believe that was already covered by alanhardisty in the earlier posts?
0
 
MegaNuk3Commented:
Yep, alan has mentioned it already.
0
 
pchristopher52Author Commented:
I found this on another site but don't know how to run it:


Posts: 8
Joined: 23.Mar.2007
Status: offline       Figured it out...

Even though the user accounts were enabled for activesync in EMC I ran the following command in EMS:

Set-CASMailbox -Identity <SMTP Address of user> -ActiveSyncEnabled $true

Does anyone know how to run it?
0
 
Alan HardistyCo-OwnerCommented:
That is a Powershell command for Exchange 2007 / 2010, which you don't have, so you can't run it!
0
 
MegaNuk3Commented:
Upgrade to E2k7 or E2k10 ;-)
0
 
pchristopher52Author Commented:
I found a fix. It was in http://support.microsoft.com/kb/937635. All of my setup did not match the set up in the kb. Once I made the changes it started working. Thanks to all for their helpful comments.
0
 
Alan HardistyCo-OwnerCommented:
My Exchange 2003 / Activesync article refers to the KB article that you suggest was the solution to your problem:
"For Small Business Server 2003 Users - please check this MS article - http://support.microsoft.com/kb/937635"
 
0
 
Glen KnightCommented:
I agree, comment ID: http:#32334911 is the correct answer and should be accepted as the solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.