XenApp not mapping client printers

I am deploying a new Citrix farm running Xenapp 5 and have run into an issue with printing. The client printers is not mapped automatically when trying to print from different applications.

Os: Windows 2008 srv 32-bit ( I also have a Windows 2008 64-bit server in the same farm)

I have a printingpolicy as follows:
AutoCreation: Enabled
Native Printer Driver auto-install: enabled , Do not automatically install drivers
Universal driver: Enabled, Use Universaldriver only


I'd appreciate any ideas or insight into the problem, thanks!
cowiekspertAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike ThomasConsultantCommented:
With PS 4 / 4.5 you had to import the print servers if the clients were using network printers, have you done this?
Daniel BorgerSenior Citrix Engineer- CCEECommented:
Any settings in the ICA listener? Under terminal services configuration.
cowiekspertAuthor Commented:
When I was finish with the XenApp installation, i tried to print from Excel and all my local network printers was automatically mapped. A couple of days later when I tried again, none of my printers are mapped. I have`nt done much in the meantime, that should affect the printing. I dont think :)

rgds,
Hanne
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Daniel BorgerSenior Citrix Engineer- CCEECommented:
Have you restarted the print spooler service on the server?
cowiekspertAuthor Commented:
Yes, and the Citrix Print something service
Daniel BorgerSenior Citrix Engineer- CCEECommented:
cowiekspertAuthor Commented:
Disable Windows Client Printer Mapping and Disable Client LPT Mapping is checked and greyed out in ica-tcp listner.

cowiekspertAuthor Commented:
I have disabled a couple of Policies, as suggested in this article: http://support.citrix.com/article/CTX104693, this was a link from the article you suggested. But the Disable Windows Client Printer Mapping and Disable Client LPT Mapping is still checked and greyed out in ica-tcp listner. maybe this article is a bit out of date?

Kind rgds,
Hanne
Daniel BorgerSenior Citrix Engineer- CCEECommented:
Sounds like you may have a GPO restricting this. that would explian why it worked and then did not after the policy was applied and the server rebooted.
do a Gpresults on the server and see what policies are being applied.  if any are they would be (“Do not allow client Printer redirection” and “Do not allow LPT port redirection”)
They would also be represented in this registry key. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\ICA-tcp
cowiekspertAuthor Commented:
GPO: Local Group Policy
                KeyName:     SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fDisableLPT
                Value:       0, 0, 0, 0
                State:       Enabled

This should be Disabled right? But how do I do that? I cannot se any Policies in gpedit.
Daniel BorgerSenior Citrix Engineer- CCEECommented:
at a command prompt type gpresult and see if any other policies are applying
cowiekspertAuthor Commented:
fDisableCpm is enabled. This means: Disable Windows Client Printer. It is applies via a local group policy.
Daniel BorgerSenior Citrix Engineer- CCEECommented:
That should not be disabled.
cowiekspertAuthor Commented:
:) But how do I change them. I do not have any "Policies" in Local group Policy Editor
Daniel BorgerSenior Citrix Engineer- CCEECommented:
the policy could be coming for the organizational unit the server is in.  are you using the group policy management plug in for the MMC?

As a test you could:
Create a new Active directiry OU and move the server there. Block inheritace of polices on the OU. do a gpupdate/force on the server and test.
cowiekspertAuthor Commented:
Hi. Tried what you suggested. But same problem. It is the local group policy that is the problem. If you can direct me to where I change this policy?
Daniel BorgerSenior Citrix Engineer- CCEECommented:
the local group policy can be modified using gpedit.msc  (start/run)
cowiekspertAuthor Commented:
yes. But I cant fint the policy :)
Daniel BorgerSenior Citrix Engineer- CCEECommented:
when you open Gpedit.msc it is the local policy on the server. you can filter the view to only show configured policies.

as a test you can delete this key KeyName:
     SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fDisableLPT
and see if you get printers, although until you find the policy it may come back.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cowiekspertAuthor Commented:
This is not a Policy key that is actually a reg key. But thanks. It work now. I chnage the value from 1 to 0. That disabled the policy.
cowiekspertAuthor Commented:
solved
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.