Group Policy Logon Script to Map Printer Not Running

I have written a basic VBS script to map a printer and created a GPO attached the a computer OU, with the script defined under User>Windows Settings>Scripts>Logon.

After a GPupdate of the computer in the OU, the policy is visable under GPresult but doesn't run at logon. Under rsop.msc the script is not shown.

We are running Server 2003 DCs with Win XP Clients

The script is:
"
' Printers.vbs - Windows Logon Script.
Set objNetwork = CreateObject("WScript.Network")
objNetwork.AddWindowsPrinterConnection "\\server\printer"

"

HelpDeskECAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slavetononeCommented:
Have you tried to force the gpupdate on any of the computers listed in tour computer OU to see if it can grab it manually?
0
HelpDeskECAuthor Commented:
Hello,

I have tried the GPupdate /force command but with no success
0
Justin EllenbeckerIT DirectorCommented:
You have the settings defined for users, but because you have it linked to computers turn loopback processing on in the GPO.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Justin EllenbeckerIT DirectorCommented:
Here is the MS KB about it:

http://support.microsoft.com/kb/231287

"You can use the Group Policy loopback feature to apply Group Policy Objects (GPOs) that depend only on which computer the user logs on to."
0
HelpDeskECAuthor Commented:
When turning loopback on, the script run and maps the printer correctly!... but it locks down even domain admin accounts to one of a restircted user, as definded in other policies - no cmd ect.

Is there anyway around this?

0
Justin EllenbeckerIT DirectorCommented:
You can block the policies from being applied to Domain Admin accounts

http://support.microsoft.com/kb/816100

We do this on all of our terminal servers because we get the same issues as you describe other wise.  That KB article will walk you through blocking a policy from applying to certain users or groups.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.