Windows 2008, CF 9 and application pool that keeps shutting down

I am running Windows 2008, IIS 7.5 and Coldfusion 9 in a virtual environment using VMware.  Suddenly last week the application pool that this IIS instance uses keeps shutting down for no apparent reason.  This is in a development environment so there is really only a few people hitting it.

I wanted to see if anyone had any idea of why this might be happening.
Thanks
LVL 2
WebStalkersAsked:
Who is Participating?
 
WebStalkersConnect With a Mentor Author Commented:
I ended up changing the default user on the application ppol from AppPoolIdentity to NetworkService and things have worked great now.  
0
 
WebDOTCommented:
does anything show up in the application event log?
0
 
WebStalkersAuthor Commented:
The only thing I can find is this:

Faulting application name: w3wp.exe, version: 7.5.7600.16385, time stamp: 0x4a5bd0eb
Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b
Exception code: 0xc0000005
Fault offset: 0x00000000000159ad
Faulting process id: 0xe74
Faulting application start time: 0x01cae6de1a0b53c1
Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 57cc2398-52d1-11df-b71c-005056af0fca

0
 
WebStalkersAuthor Commented:
Here is another thing I am noticing and not sure if this is related to this issue but I thought I would throw this out there. When I select this IIS 7.5 instance and go into 'Basic Settings' I select 'Test Settings'. I get an ok on the Authentication but I get an error on the 'Authorization'. 'Cannot verify access to path (D:\....'.

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.
0
 
WebStalkersAuthor Commented:
done
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.