HP Procurve 2610 - 2VLAN's - Routing in between

Hi,

I do have a small problem to solve.

Scenario:
I want to use a HP Procurve 2610 as a router between 2 networks.
I created 2 VLANs (IP VLAN1: 10.100.100.1/24 - VLAN2:10.100.140.1/24)
I activated 'ip routing' in the CLI.
In the first VLAN I have an external router that also is my gate to the internet. It has the IP address: 10.100.100.254.

I also added a zero route in the switch:
ip route 0.0.0.0/0 10.100.100.254

A computer that is connected to VLAN1:
IP: 10.100.100.100 /24
GW: 10.100.100.1

is able to surf the internet and has access to 10.100.100.254


A computer that is connected to VLAN2:
IP: 10.100.140.10 /24
GW: 10.100.140.1

is NOT able to surf the internet and has NO access  (no ping) to 10.100.100.254.


Now if I enter
 show ip route
within the CLI, I get:

Destination: 0.0.0.0/0
GW: 10.100.100.254
VLAN: 1
Type: static

What do I have to do to be have internet access and communication with 10.100.100.254


Thanks in advandce....
csc4lsbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atrevidoCommented:
your show route command should have had default routes automatically configured between your directly connected (aka in the box) vlans.
Is this a production switch?  I assume you turned on IP routing after creating the vlans.
Then you'll ahve to try this:
Login
config
erase startup-config
box "reboot"
Login again
first command is ip routing
set up your vlans again and ip routing should have more routes.  This won't get you from your vlans to the internet route though.
then retype your ip route command
ip route 0.0.0.0 255.255.255.0 10.100.100.254  
and everything should work, except I'm concerned about your tagging, hence the below request for show run
Which port is the internet router connected to?
can you post a show run please
0
jburgaardCommented:
On  the 10.100.100.254 you need a route to 10.100.140.0/24 via 10.100.100.1
HTH
0
atrevidoCommented:
jburgaard, that route should be inherent and already present based on HP Procurves direct connect routing strategy.  It should not have to be entered
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

jburgaardCommented:
csc4lsb,
as far as I can see, your setup is OK:
-your client PC's do have their vlan-IP's as dgw's

-your sw's dgw is correct set to the IP of router with:
ip route 0.0.0.0  0.0.0.0  10.100.100.254  

-only you did not mention settings on the 10.100.100.254 - router,
and here a route back to vlan2 IS needed.
0
csc4lsbAuthor Commented:
Here is what I got so far...

I erased the startup-config and set the ip routing again.
Then I created the VLANs (WEB browser) and finally listed the IP routes. The attached picture.


The device (IP: 10.100.100.254) is a Astaro Firewall, which is hooked to 10.100.100.0/24 on port 1 and has a internet connection on port 2.
I still can surf in the internet within the 10.100.100.0/24 range but don't have a valid communication when within the 10.100.140.0/24 range.
I even not able to ping the router itself or a computer that is hooked in VLAN1 on the switch (e.g. 10.100.100.100)

On the Astaro I created a static route from 10.100.140.0/24 into the 10.100.100.0/24 range.

Thanks again in advance.
Capture.PNG
0
atrevidoCommented:
please post a show run of your entire switch config
0
csc4lsbAuthor Commented:
Hey there,

I solved it. I set up a interface static route on the Astaro. Unfortunately this is the mistake.
After changing the static route to a gateway routing, everything is working fine.

Thank you very much for all your answers and hints.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jburgaardCommented:
Glad you got it working.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.