• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1243
  • Last Modified:

this is a pre-release version of the compatibility pack

I have an older Citrix/Terminal server running Windows 2000 SP4 with Microsoft Office XP (2002) SP3 that has been running without problem for several years.  Over the weekend I applied Microsoft's latest security patches (released in April 2010) and now the Office application will not open documents created in Office 2007.  

Here is the actual message that pops up:
This is a pre-release version of the Compatibility Pack and can open pre-release Office 2007 files only. Do you want to check for a newer version of the Compatibility Pack?

We have never used a beta version of any program on this server and I know it was working correctly last week; therefore, I am working on the assumtion that one of the several patches Microsoft put out in April (Windows 2000, Office XP and Office 2007 patches) has caused the Compatibility Pack to "think" it is a pre-release version.  I have already tried removing the original Compatibility Pack, rebooting and then reinstalling the latest Compatibility Pack from Microsoft's web site (1/6/2010 version).  No change.  I also tried the Office 2007 converter administrative template with the group policy editor suggested by Microsoft.  No change.  I can not do the manual registry hack they suggest for the HKeyCurrentUser policy setting as this is a Citrix server so every user on the system, of course, has their own HKCU settings.  Has anyone else run into this and if so are there any other fixes I can try?
0
DShryer
Asked:
DShryer
  • 3
1 Solution
 
bigbunk390Commented:
I'm not sure about how to resolve your issue but I will offer a possibility.
The HKCU key, if you wanted that to apply to users you should copy the key to a file in the proper format and name it something.reg, copy the file to the C drive.

Open a file called usrlogon.cmd in the system32 directory. Under the @echo off  line,
enter
regedit.exe /S c:\something.reg

save and exit
When a user logs into the citrix server it will run that reg file silently importing the key into the users HKCU..

0
 
DShryerAuthor Commented:
Thanks for the info.  Just to let everyone know, I did try the HKCU registry setting for my own account on the server just to see if it would make and difference and it did no good at all.

The info you gave may come in handy for other issues though so thanks.
0
 
DShryerAuthor Commented:
I found a solution myself on another site.  Here is how to fix this problem for anyone else that might have the same problem.

We have the same issue. There is also an issue of being unable to open
(convert) .xlsm files. This only occurs on our Windows 2000 PCs with Office
2003 & the Office 2007 Compatibility Pack.

977724 (and some later updates) updates MSO.DLL in

C:\Program Files\Common Files\Microsoft Shared\OFFICE12

977724 does not show up in Add/Remove programs, but I was able to find an
older version of MSO.DLL in the Windows Installer patch cache:

C:\WINNT\Installer\$PatchCache$\Managed\0000210902 0090400000000000F01FEC\12.0.6425\

To verify that the problem is caused by the MSO.DLL from 977724, I renamed
the MSO.DLL in

C:\Program Files\Common Files\Microsoft Shared\OFFICE12

& copied the MSO.DLL I found in the patch cache to the above location. I was
then able to open (convert) .docx files in Word 2003 & .xlsm files in Excel
2003.

The version of MSO.DLL installed by 977724 is 12.0.6521.5000 & is dated
10/29/2009.

The last version of MSO.DLL that works correctly with Windows 2000 is 12.0.6425.1000 & is dated
04/03/2009.

0
 
DShryerAuthor Commented:
Please leave the question in the system so that others can benefit from the solution I just posted on how to fix this problem.
0
 
LuRuCommented:
solving this problem cost me one day before finding your solution. I am also using Windows 2000, Office 2003, and tried to restore files in
\program files\microsoft office\office12
and
\program files\microsoft office\office12\1033
with old versions, this did NOT help. Finally I exchanged
MSO.DLL in
\program files\Common Files\Microsoft Shared\OFFICE12 with file version
12.0.6562.5003 (dated 27. July 2011, quite more recent than the one DShryer descibed) and this
worked!

Obviously, installing Compatibility Pack (version 4) does not replace the MSO.DLL with the newest version.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now