Workgroup Settings not saving??

I'm administering a Apple Server OS X Leopard(not snow leopard). I'm in the Workgroup manager trying to provide an account with access to approved programs such as iMovie, iPhoto and Garageband and etc. It allows me to add all Applications fine but when I go to hit Done or Apply Now I get an error : "Error while saving record "student": Error: -14140" . What is causing this, I really need these students to have access to this software in the near future and from what I have been told even when the students click to run the programs on their iMacs the system tells them that they do not have priviledges or access to use the program. Please advise?
corporateKeenanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Is this happening with all users?

Have you tried applying the preference settings to a group and then adding the users to the group?
0
corporateKeenanAuthor Commented:
No I haven't I will give this a try shortly.
0
EdTechyCommented:
Are you bound to Active Directory?
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

corporateKeenanAuthor Commented:
Yes I'm bound to Windows 2K3 R2 Server Active Directory.
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Was the user created in OD or AD?
0
corporateKeenanAuthor Commented:
@nappy_d I tried your suggestion with the group I got the same error message. I'm logged in as a Admin user and not the Root does this matter any?
0
EdTechyCommented:
You will have to create an LDAP group on the mac server, then add your ad users or ad groups to the "Mac" group. You can not apply WGM settings directly to AD groups or users.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
This is a bit dated but I think will help you http://www.afp548.com/forum/viewtopic.php?showtopic=16200
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.