Group Policy? Generic Text Printer Not Printing Over IP

I have a label printer that is set up in Windows as a Generic Text printer.  I know the printer is ok because I hooked it directly into a computer with a cord and configured it that way and it works fine.  I'm trying to set it up to print to a TCP/IP port on our network and the print job gets to the printer and just hangs and never goes anywhere.  

Is there a Group Policy that would block something like this?  The reason I ask is because this stopped working when I changed domains at this location.  I removed their old domain and made them part of our main domain, which has more security and policies.  

I don't think it is a rights issue as I installed this printer on our main server as the administrator and had the same issue as the XP clients.  And, like I said, it works when plugged in with a cable and shared.  I'm just having trouble giving it a TCP/IP port that works which I've tried on the server and the XP clients.  

I also went into our little print server (the IP source) and changed IP addresses on it and still nothing.  

Any ideas?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

If your print server is a Windows server then you cannot print to it's IP address. However, there are utilities that let you do so. Did the IP addresses get changed as well, when you changed domains?

If it is an external printserver (a little box with network input and parallel/usb output) then you should be able to get it to work. Check that you can ping it from the PC. If the printserver uses a parallel port it should work just fine. If it uses usb there are other issues.
FH_JGoodwinAuthor Commented:
It is parallel into a little print server with an IP. I actually reset the device and gave it a new IP to test of which I can ping.

It was set up this way before (it's port set as a tcp/ip port). The domain I changed to has much more tightened down security in it's default domain policy.
It is possible that your network now stops certain protocols. Can you print to other printers on the same subnet via a TCP/IP port?

We may also need to check which protocols the printserver supports, LPR and/or RAW. This is important if it has multiple parallel ports. And the PC's TCP/IP port needs to be set appropriately. If you know how it was set up when it was working, set ip up the same way.

What is the brand & model of the printserver?
FH_JGoodwinAuthor Commented:
I put a different brand of print server (Dlink) and that one worked.  Guess the old one was incompatible with Windows 2008.  

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.