Exchange 2007 'Delivery has failed to these recipients or distribution lists:'

Hello,

I know there where serveral diffrent posts about this but my question is a little diffrent.

So I setup a new mailbox lets call it HR. I assigned additional email addresses to the mailbox so currently it has 3 email addresses configured:
hr.mailbox@domain.com
hr@domain.com
employment@domain.com

I gave a user the Full permission to the mailbox and I also added the user to the list of users which have the 'Send on behalf permission' in the 'Delivery Options' of the mailbox. I then also changed the the primary email addres from hr.mailbox@domain.com to employment@domain.com.

Now if the user puts hr.mailbox@domain.com into the FROM field when he sends an email then the email is being delivered without a problem. But if he uses employment@domain.com. then he receives a bounce back mail with the following content:
=============================================================================
Delivery has failed to these recipients or distribution lists:

happyness@yahoo.com
You are not allowed to send this message because you are trying to send on behalf of another sender without permission to do so. Please verify that you are sending on behalf of the correct sender, or ask your system administrator to help you get the required permission.

Diagnostic information for administrators:
Generating server:

happyness@yahoo.com
#MSEXCH:MSExchangeIS:/DC=com/DC=domain:EXCHANGE1[578:0x000004DC:0x0000001D] #SMTP#
=============================================================================
I did all these changes yesterday - so if these changes are not applied on exchange server right away by now they should, no?

What am I doing wrong? I need to enable the user to send emails from employment@domain.com

Thank you
Mc2102
Mc2102Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shauncroucherCommented:
You can't do that. You can only send as primary email address.

After each change, restart the Information Store service to be sure it has taken place.

Also, you should choose either Send As OR Send on behalf, if both are set, they will conflict.

Shaun

0
Mc2102Author Commented:
Hello shauncroucher,

I understand the part with the primary email address - this is why I changed it to employment@domain.com. I also only assigned the user the "Send on Behalf" permission.

I did not restart the Information Store yet - I will give that a try and see if that helps.

Thank you
Mc2102
0
shauncroucherCommented:
Also make sure that the user can reach the user account BY USING THE GAL (or OAB if cached mode is used).

Instead of typing the email address, select the user by clicking the FROM button.

The account must be visible and reachable through the GAL (OAB for cached mode). You can download the latest OAB by closing and reopening Outlook or Send/Receive options - Download Offline address book.

Shaun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mc2102Author Commented:
Shauncroucher,

You are a genius. In Outlook I started a new email and instead of typing in the email address manually - employment@domain.com - I simply choose the mailbox from the GAL and then it worked just fine. It shows the new primary email address as in the GAL. Now I can even type in the email address manually and the email is being send out without a problem.

That issue is strange but looks like by sending an email from the mailbox and choosing the mailbox from the GAL fixed the prblem.

Thanks a lot again.
Marcus
0
shauncroucherCommented:
Glad I could help,

Shaun
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.