Change external URL of Companyweb from RWW in SBS2008

We recently upgraded from SBS2003 to SBS2008. For a multitude of reasons, the old server was configured such that the external domain for the Remote Web Workplace, OWA, etc was listed as secure.domain.com, rather than remote.domain.com.  As such, the trusted SSL certificate was purchased for that specific domain as well (and has 2 years left on the 4 year term). I am trying to avoid having to purchase another SSL certificate to change the domain name.

I have changed the site bindings for the SBS Web Applcations site in IIS7 to secure.domain.com, rather than remote.domain.com.  DNS records are updated and the site is working for RWW, OWA and the TS clients.   However, when you go to the internal website, it changes the URL to https://remote.domain.com:987. For now, there are still dns records for "remote" and to IIS the port matters (with https) and the host header doesn't, so the website is delivered, but so is a cerificate error since the url doesn't match.

How do I change the companyweb site to work as "secure.domain.com:987" instead of "remote".  The only bindings for the companyweb are "companyweb" for http and the SSL port of 987 (which makes sense because this is all IIS needs). I guess the biggest question is do I just need to get the RWW main page to change the link for that option, or do I have to make a configuration change on the sharepoint side, or both?

Any help is appreciated! Thanks.  
LVL 1
bigintegrationAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bigintegrationAuthor Commented:
Well, as it turns out, I figured it out. It was actually pretty simple, and in case anyone else runs across this...

On the operations page for the Sharepoint Central Administration, there is a link to edit the URL for the web application. Changed that from "remote" to "secure" and all appears to be well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.