Microsoft OLE DB Provider for SQL Server error '80004005'

Help,

I'm in the process of moving the websites that we manage and host from our old server (windows 2003 - iis6 with a remoote MS SQL 2008 daabase) to our new server - (windows 2008 web edition - IIS7 with local MS SQL Web Edition).

We also have some websites on a reseller account.

I have created copies of the existing databases on the new server.
I have changed the connection strings for the websites hosted on the reseller account, these connect to the database no problem.

I've changed the connection strings in dreamwaever, for the sites currently hosted on the old server (and tested the connection string in dreamweaver on my local pc) but, when i upload the new connection strings (to the old web server) and test the websites currently hosted on the old server I get the following error -

"Microsoft OLE DB Provider for SQL Server  error '80004005'
[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
/index.asp, line 19 "

I was hoping, because of the shear number of websites, just to change the database connection strings file, for each website on the old server, pointing to the new database.

So that I could then start the transfer of the actual websites over the weekend....

I really can't see what is causing this issue..

Help please
garethtnashAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sarabhaiCommented:
yes, you need to check,
SQL Server does not accept or recognize the login account and/or password you submitted.

so please check it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
garethtnashAuthor Commented:
Thanks Sarabhai, but its the same login account server ip address and password that I'm using when i test the connection strings in dreaweaver locally. they all work fine from my local PC, it is only when I uploasd them to my old server that they fail?
Any thoughts please?
Thank you
0
tanujchandnaCommented:
Hi,

1. Do you have two users for your database. If yes then use the main user which is bind with your tables and problem should go away for you.

2. Or if you are using the following in your connection string

Integrated Security=True;Trusted_Connection=Yes

then make them

Integrated Security=False;Trusted_Connection=No

and problem should go away for you.

3. Or create new database, Restore this database on new one and create a single user for it using db_owner permission

and problem should go away for you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.