Etherchannel Stackable Switches

How do you set up stackable switches both etherchanneled and with 2 vlans for 2 subnets?
Jack_son_Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GJHopkinsCommented:
The specifics will depend upon the model you want to work with. Do you have anything in mind ?
Jack_son_Author Commented:
Probably like 3750's
GJHopkinsCommented:
Two 3750s in a stack will look like a single switch, the Etherchannel configuration will depend upon what you want to do. For example you may have an access port Etherchannel to a Server or a Trunk to another switch

some example configs below, but it all depends on what you want you are trying to achieve.


vlan 10
 name VLAN10
 
vlan 11
 name VLAN 11
 
interface vlan 10
 ip address 10.10.10.10 255.255.255.0
 
 
interface vlan 11
 ip address 11.11.11.11. 255.255.255.0
 
!
! Etherchannel Access Ports
!

interface Port-channel10
 switchport access vlan 10
 switchport mode access
!
interface Port-channel11
 switchport access vlan 11
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport access vlan 10
 switchport mode access
 channel-group 10 mode on
!
interface GigabitEthernet1/0/5
 switchport access vlan 10
 switchport mode access
 channel-group 10 mode on
 
interface GigabitEthernet1/0/5
 switchport access vlan 10
 switchport mode access
 channel-group 11 mode on
!
interface GigabitEthernet1/0/5
 switchport access vlan 10
 switchport mode access
 channel-group 11 mode on
!
! Etherchannel Trunks
!
interface Port-channel1
 description to another switch
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,11
 switchport mode dynamic desirable
 
 interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,11
 switchport mode dynamic desirable
 channel-group 1 mode active
 !
  interface GigabitEthernet2/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,11
 switchport mode dynamic desirable
 channel-group 1 mode active
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Jack_son_Author Commented:
Ok, thanks;  also its a cross stack etherchannel so this should work?  

When I do the VLan's, I can assign on separate subnets as well?
Aaron StreetTechnical Infrastructure Architecture and Global Network ManagerCommented:
you want an ether channel to span separate VLANS? this would work if you are trunking over the etherchannel but not sure how you would use it for access ports.

Also you don't need any configuration on the physical ports apart from the

#channel-group 11 mode on/acitve/passive...

any config set on the #int portchannel will be applied to the physical interfaces that are part of the group.

and this only works with switchs that are stacked with stacking cables, and are managed as a singel switch.
Jack_son_Author Commented:
Yes, I believe I will trunk them.  

Also, for the mode active/passive - do you pick one port on one switch for active and one for passive?
TAMSCODANCommented:
Recommended is ACTIVE/ACTIVE
The ACTIVE/PASSIVE - Link aggregation occurs if negotiation is successful.
ON/ON - Link aggregation occurs without LACP. Although this works, it is not recommended.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094470.shtml 
GJHopkinsCommented:
Note that there are two methods of Etherchannel negotiation that you can use on Cisco switches  PaGP  and LACP. Only LACP works with the cross stack etherchannel.


Sorry if I misled with the config on the physical ports - just cut and pasted from a running switch  as DevilWAH said just make any changes on the portchannel interface.

VLANs are by definition represent a single  subnet as they are a single broadcast domain  so different VLANs equal different subnets you will see that I have different IP addressing for VLANs in the example.

However the switch doesn't need to have a VLAN interface in a VLAN it carries unless you want to:

reach the switch on that IP address

router traffic to/from that VLAN.
Aaron StreetTechnical Infrastructure Architecture and Global Network ManagerCommented:
I am jsut finishing of the new CCNP switch exam, and in that they actuly suggest using

#channel group x ON

on both sides of a link rathert then use automatic settings, espicaly if i is a switch to switch link.

for servers they suggest setting the protocol as lacp and allow the servers to negoitate. (LACP is the standard where as PAGP is cisco propriorty, and to be honest there is no benifit of using it, it is older than LACP and is being phased out by cisco, proformace wise there is zero difference)

for this you set

#channel-group protocol LACP (or PAGP)
#channel-group 1 passive.

this will then only form a etherchannel, if you set the server to acivily seek it.
Aaron StreetTechnical Infrastructure Architecture and Global Network ManagerCommented:
On = part or ether channel, no negotation, so if you set tow ports on one switch to be part of the same group then they will form a channel regardless of what each is connected to..

Passive  = will respond to other switches who send LACP advertisement packets, but will not activly seek to become a channel. (two ports in the passive linked together will not become a channel)

active = port will both send advertisement that it wants to be a channel, and accept other switches advertising. if it receives an advertisement from another active port, it will act the same as a passive port.

on + on = channel

active + active = channel

Active + passive = channel

passive + passive = no channel

There are no hard fast rules how to set these up, I have suggested a few above. On thing i will say if make sure the groups numbers match on both sides of the links. You can get some funny results if you mix them up..
Jack_son_Author Commented:
Will this be the same for cross channel etherchannel configuration
Jack_son_Author Commented:
Actually, so I will need a trunk to use 2 vlans and subnets?  I wanted to use just the cross stack etherchannel to interoperate.  If I use just 1 vlan with the cross stack, I wont require the trunk then?

Jack_son_Author Commented:
Also, I see in your config there are 2 port channels, one for each subnet and vlan?
GJHopkinsCommented:
The port channels 10 and 11 show an example of two access etherchannels, say to two servers both in vlan 10.

The port channel 1 example shows a etherchannel trunk to another switch and carrying vlan 10 and 11

Yes if you have one vlan you could use an access port channel between switches. However a trunk gives you more long term flexibility if you need to add other vlans.


Jack_son_Author Commented:
Thanks for all the clear info.  So the trunk lets you add more vlans easier.  I am thinking I may extend to more vlans later, so then the trunk would be necessary?
GJHopkinsCommented:
If you start with a trunk and add vlans they will be carried on the trunk, if you have an access port then you will need to re-configure the switches. There are also commands to restrict the vlans allowed on a trunk if you need to limit their scope

example

switchport trunk allowed vlan 34,105,129

Jack_son_Author Commented:
Also, can ther be multiple port channel interfaces on teh cross stack etherchannel setups?
GJHopkinsCommented:
Yes, each port channel interface is an etherchannel. Define as many as you need.
Jack_son_Author Commented:
THanks, one final issue, for layer 2 switching can there be 2 vlans configured?  It seems that there is an issue getting them working on this switching setup
GJHopkinsCommented:
Yes as many as you like ( up to 4096) with extended van ID
Jack_son_Author Commented:
Ok thanks.  I was having an issue, maybe it was because I was using int vlan 2 vs vlan 2; seems that one of the vlans wasnt working.
GJHopkinsCommented:
Yes a layer 2 switch will usually have only one van interface for management but will support multiple vlans
GJHopkinsCommented:
If it is a layer 3 switch make sure you have the command

ip routing

In the config if you want to have multiple interfaces and be able to route to them all

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jack_son_Author Commented:
Thanks again, so it has to have ip routing if I route the 2 vlans with int vlan 10 and int vlan 11?

Thanks for all the info again....
GJHopkinsCommented:
if you want to pass traffic between the two vlans then you need routing. If you just want two vlans to exist then you don't need routing.

It may help to think of the VLAN as a wired network with its own network address.  if you wanted to pass traffic between the two wires then you would need to connect them to a router, a bridge wouldn't do as they are on different IP networks.

Turning in ip routing is the same as adding a router between the two wires - its just that a switch is much more flexible - guess that's why we use them :-)

GJHopkinsCommented:
if you want to pass traffic between the two vlans then you need routing. If you just want two vlans to exist then you don't need routing.

It may help to think of the VLAN as a wired network with its own network address.  if you wanted to pass traffic between the two wires then you would need to connect them to a router, a bridge wouldn't do as they are on different IP networks.

Turning on ip routing is the same as adding a router between the two wires - its just that a switch is much more flexible - guess that's why we use them :-)

Jack_son_Author Commented:
Thanks for all the information, it was a huge help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.