Crystal error : The table cannot be found

Hi Experts,

I have a problem with one of my weekly reports scheduled to run every Monday morning. When I look in the CMC for the error message it gives :

Error in File ~tmp*****.rpt: The table could not be found.

When I remotly control my server where Crystal Reports 2008 is installed, I can run the report without problems with all the same accounts.
I also did a "verify database" on each sub report and the main report.
Nothing have changed in the report, so I don't really know what is causing the problem.
--> There are 7 different databases for this report, so the error message don't tell me which of these databases is the problem.
I even tried to import the report with another name and run it in the CMC, same message!

Does anyone happen to have this problem before?
LVL 1
EtdashouAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LinInDenverCommented:
I've only had this happen when a DBA changes something without letting me know first! I.e.: Change of table name, Removing permissions of user to table...

Make sure that you are testing with the same database user account the report is scheduled under...
0
mlmccCommented:
Are any of the subreports set to reimport when opened?
If so is that report file available?

mlmcc
0
EtdashouAuthor Commented:
Well since the report runs by itself on my PC or on the Server with all the save connections and then I import the report as a new report with a complete different name in the CMC, I don't understand why I cannot run it in the CMC?

- The option for reimport is not check anywhere.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

LinInDenverCommented:
Are you using Crystal Reports Server 2008 as well?

Also what type of database are you connecting to, and what ODBC driver are you using?
0
EtdashouAuthor Commented:
Yes Crystal Reports Server 2008,

Here are the database I'm connecting to :

1) Oracle 10g database (Service Manager 7)
2) Sybase (Symposium)
3) Lotus Notes (for 2 tiles)
4) MS SQL (NTR)

I hope this could help
0
LinInDenverCommented:
Thanks!

In looking on the SAP forums there is a lot of talk of people with your error and who don't have the server configured correctly - namely where the CRS services on the service are running under a local account and not a domain account. I know it doesn't sound like it makes sense, but that is often the case with Crystal. ;-)

See if this link will open up for you. This talks about an older version, but it could still apply.

http://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/oss_notes_boj/sdn_oss_boj_erq/sap%28bD1lbiZjPTAwMQ==%29/bc/bsp/spn/scn_bosap/notes%7B6163636573733d36393736354636443646363436353344333933393338323636393736354637333631373036453646373436353733354636453735364436323635373233443330333033303331333233363334333633333331%7D.do


In addition, you might want to try publishing each of your sub reports individually to see which one is actually throwing the error. I'd be suspicious of Lotus Notes before the others, but you never know...
0
EtdashouAuthor Commented:
Thanks a lot for the heads up.

I now see that the problem began when I tried to install the AD SSO on my crystal server (and I didn't succeed yet).  During that project, I changed the account for each item in the CCM.

I changed the account for the same thing I use in my report (the service account), but the problem is still there. Maybe I don't put the right thing there!

--> I'm not sure I understand what is the difference between "Local System Account" and "domain account"?

In addition, I tried to publish my sub-reports individually, and all of them (14 sub-reports) were successful. and I don't have any database connected to my main report.
0
LinInDenverCommented:
Wow all 14 worked - this just gets weirder and weirder...

Any chance you can add a connection to your main report? it really should not make a difference (i've done this as well), but maybe it is hosing up there. maybe just to one of your Oracle database just make a command that is select 0 from dual

By Default, CRS2008 installs and runs services under a local system account. this can cause some problems later (i.e.: when you try to schedule to a file location it will force a user name and password each time, trying to configure LDAP, etc.).

I had our NT guys set up a service account on the company's domain (svcCrystal, something like that, this account's password never expires, and also can never login, but can authenticate to LDAP, etc.), and changed the BO services on the machine to run under that account.

The services (from Windows Control Panel, Administrative Tools, Services) I applied this to were: Server Intelligence Agent (yourservernamewillbehere) and BOE120MySQL. You may not have BOE120MySQL if you chose to use a different database for your system data (MySQL is the default on install).
0
EtdashouAuthor Commented:
Hi Lin,

I did a lot of test on my report.
First of all, I tried changing all BO services to the default  local system account. doesn't work, same message
Then, I changed all BO services to my service account, same message.
Then I added a database to the main report, same message, grrr.

Do you know if your service account have special rights?
0
LinInDenverCommented:
Hi etdashou, that really stinks. :-( My NT service account has very limited rights - just the ability to see LDAP and see our shared drives...

Did you also test with adding a connection to the main report?
0
EtdashouAuthor Commented:
Yes I did, nothing works. I was also afraid that my monthly reports would not run this past weekend, but everything worked fine. The problem is only with that report (I must say it's the most complicated report I have, with 14 sub-reports...).

At least I know it's related to one of the database, but I don't know which one! Beside running each subreport individually, do you have any other way arround to know which one could be the problem?
0
LinInDenverCommented:
I can't think of anything else except to make sure you have the latest service packs/hot fixes installed.

You might want to poke around on the SAP forums a little more - there are some pretty smart people on there, some of whom actually work for SAP. http://forums.sdn.sap.com/category.jspa?categoryID=45

If all else fails, open up a technical support message - the system should be able to handle this!
https://websmp107.sap-ag.de/support <--you need to have an S-ID to log in and open a tech support message.
0
EtdashouAuthor Commented:
Thanks a lot for your help Lin, I will look with SAP to solve my problem.
I will get back with the solution when I have it!

Thanks again!
0
EtdashouAuthor Commented:
Problem solved! worked with SAP on the issue and they helped me with one thing : find the log.

The message "Table cannot be found" doesn't tell which table is the problem, but in the log you can find it. Here's how to creat logs :

In you CMC, go into the server section, then properties of the "crystalreportsjobserver".
In there, you will see a section named "command line parameters"
Look into this command line if there are those :

-trace
-crpetrace 7

If not, add them at the end with a space between them.
Once you do that, reschedule you report so the log files can be created.
The log files will be there ; Program Files\Business Objects\BusinessObjects Enterprise 12.0\Logging
(or something like this, depending of how you installed your BO.

Find the error message in the log, it should help you. It gave me the exact table where was the problem
At least i could do more specific tests because of that.

--> I solved my problem when I realized that the subreport where was the problem was connected directly to the database , not with a SQL command. I then created a SQL command for that subreport and it worked perfectly (also saved a lot of time to run the report).

(Thanks Lin for all your help)
I hope this solution can help others.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB Reporting Tools

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.