Error running ASPX

I'm getting this error from my IIS server when running an ASP.NET app:

Could not load file or assembly 'CrystalDecisions.Web, Version=10.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified.

I know that crystal report now comes as part of .NET, but I'm not using it, and I removed all the references to it from the list of controls in the toolbox.  

Can anyone help me with this?
LVL 1
HLRosenbergerAsked:
Who is Participating?
 
HLRosenbergerConnect With a Mentor Author Commented:
I have solved the problem.  Just delete the tag in the default.aspx file that references Crystal.
0
 
Tray896Commented:
It sounds to me like something is still trying to load some crystal components.  You may need to get and register the Crystal dlls.

See here for more info: http://community.sgdotnet.org/blogs/darenhan/archive/2009/12/30/could-not-load-file-or-assembly-crystaldecision-web-version-10-5-3700-on-web-page.aspx
0
 
Carl TawnSystems and Integration DeveloperCommented:
Have you just removed it from the Toolbox, or have you also removed any entries in the References section of Solution Explorer?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
samsymonCommented:
if you are sure that you are not using it then check for the entries in web.config
also make a search in entire solution with crystal.
if anything you found just remove the entries.

the above is because crystal report services is not in GAC and you have refered it some where.

if you only want to run the application then install crystal report from

http://support.businessobjects.com/communityCS/FilesAndUpdates/cr120_redist_install.zip.asp

http://social.msdn.microsoft.com/Forums/en/vscrystalreports/thread/b70c896a-6844-48bb-a966-63a3f589a0f1
0
 
halfbloodprinceCommented:
Try adding this code to your .config file & then compile:

<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
</httpHandlers>
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</httpModules>
0
 
HLRosenbergerAuthor Commented:
carl_tawn:

I only removed it from the toolbar.  How do I remove it completely from the project?
0
 
Carl TawnSystems and Integration DeveloperCommented:
If you look at the Solution Explorer there will be a section called References. Expand that, select any Crystal Report type references and delete them.
0
 
HLRosenbergerAuthor Commented:
I'm looking at Solution Explorer and I do not see anything called References.  

I did go into control panel and removed Crystal Report For Visual Studio 2008 from system.   I'm onto something here because now when I try and build my WEBSITE I get an error about Crystal being missing.  That's good.  Now, I just need to get rid of all references in Visual Studio.
0
 
Carl TawnSystems and Integration DeveloperCommented:
You should have something that looks a bit like the attached. What version of VS2008 are you using?
solexp.jpg
0
 
HLRosenbergerAuthor Commented:
Version 9.0.21022.8 RTM.   Here's my Solution Explorer:


0
 
HLRosenbergerAuthor Commented:
whoops that did not upload. MY Solution Explore does not look anything like yours.  Maybe its a config setting?
0
 
HLRosenbergerAuthor Commented:
Try this image upload again.
0
 
HLRosenbergerAuthor Commented:
halfbloodprince:

Where in the config file do I add it?  I tried at the bottom right before the </configuration> tag.  But that gave an error.
0
 
HLRosenbergerAuthor Commented:
halfbloodprince:

That did not help.  I already had that code in the config, but the only  difference as I saw it was
Version=3.5.0.0  verses  1.0.61025.0
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.