• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1807
  • Last Modified:

Slow Accessing Shared Network Drive

We just installed a new server running Windows Server 2008. Some of our XP machines are taking forever to connect to the mapped shared drive.  They eventually do connect and they can access the files but that initial connection can take between 1-2 min. Everytime they restart they have to wait again and I think after some period of time, even without restarting, they have to wait again. Do you know how I can fix this?  
0
smihelp
Asked:
smihelp
  • 7
  • 3
1 Solution
 
smihelpAuthor Commented:
I noticed that these XP machine's local area connection status says "Attempting to authenticate". The internet and network work so I'm not sure why it still says "Attempting to authenticate".
0
 
smihelpAuthor Commented:
right clicking on the Local Area Connection and choosing "Repair" removes the "Attempting to authenticate" (until the next reboot) but does not solve the slow access to the mapped folder.
0
 
smihelpAuthor Commented:
Note: These computers are not connected to a Domain. They simply have a shared folder on the server mapped as their Z:\ Drive
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
johnb6767Commented:
Look in the NIC properties (assuming this is your WIRED connection), and se if you have an "Authentication Tab, and if so, uncheck the "Use 8021.x authentication....."

Might want to get a sniff on the wire to see what those machines are trying to do. Almost like they are timeing out looking for something.....
0
 
smihelpAuthor Commented:
I unchecked "Use 8021.x authentication" and still had the same issue. I uninstalled the Netware client that's still on those machines until we get everything transfered to the new Windows server and the issue was resolved. Do you know why the Netware Client would cause the delay?
0
 
smihelpAuthor Commented:
unchecking "Use 8021.x authentication" did solve the "Attempting to authenticate" issue though. Is "Use 8021.x authentication" not needed?
0
 
smihelpAuthor Commented:
I followed the guide in this Novell Support Doc and it solved the problem without uninstalling Netware. Here's a quick walk-though:

--------------------------------------------------------
1. Run Registry Editor (REGEDT.EXE).

2. From the HKEY_LOCAL_MACHINE subtree, go to the following key:

      \SYSTEM\CurrentControlSet\Services\NetwareWorkstation\Parameters]
     
3. From the Edit menu, select New -> Multi-String Value.

4. Add the following

      Value Name: BadServer
      Value Data:
      Server IP Address
        Server Name

5. Choose OK and quit Registry Editor.

6. Shut down and restart.
-------------------------------------------
Poor performance accessing Microsoft Office documents on a Novell server.
http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=7004092&sliceId=1&docTypeID=DT_TID_1_1&dialogID=124811570&stateId=0%200%20124813322
0
 
johnb6767Commented:
No it isnt needed unless you have specifically set it up....
0
 
smihelpAuthor Commented:
Thanks for your help johnb6767!
0
 
johnb6767Commented:
NP. For some reason we have seen that setting getting changed for no valid reason....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now