Apache on WAMP (Windows 7 Pro) won't start

I have WampServer 2.0c installed on Windows 7 Pro. Apache has worked for a few months, and today decided that it didn't want to work anymore. :)

There is nothing in the error log for Apache (at least not for this issue -- there are some old errors, but those have been resolved). When I run WampServer, it starts (i.e., goes into my system tray), but Apache isn't running. I click on "Start/Resume Service" for Apache and literally nothing happens (other than the dialog going away) -- that is, it doesn't start, and it doesn't write any error to the log.

IIS is stopped.

Any help is GREATLY appreciated!
Edge WebwareAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Edge WebwareAuthor Commented:
By the way, I've searched on here to no avail for the solution to my particular problem. Other similar issues are not quite the same.
0
IanThCommented:
have you tried removing it and reinstall it
0
Edge WebwareAuthor Commented:
Yes, I just removed it and reinstalled version 2.0h (also tried 2.0c as well, to no avail). It still will not run Apache. It says that that MySQL is running fine, but Apache won't run. Obviously I can't get to MySQL since I can't get into phpMyAdmin...but it says the service is running.

...and still nothing at all in the error log.

Oh, and I can't use 2.0i because there is apparently a conflict between PHP 5.3 (in 2.0i) and Zend Optimizer, which I need.
0
IanThCommented:
try it in xp mode to see its a windows 7 problem if it is I would use vmware workstation and install a ubuntu server with lamp (linux wamp) and use that for testing instead
0
Edge WebwareAuthor Commented:
OK...I might have had a slightly retarded day yesterday, but I want to put this up here in case anybody else runs into this same issue and finds this thread.

I found the problem by looking at the Windows Application log (In Windows 7: Start  > All programs > Accessories > Run > eventvwr (then select Windows Logs > Application). Remember, there were no errors in the Apache error log. In there, I found that there was a problem with one of my Apache config files. However, since I had uninstalled/reinstalled a few times, and this was an OLD config file (from the original installation), it finally dawned on me that I needed to completely delete the old "C:\wamp" folder when I uninstalled it, since there were residual files still in there.

So...I uninstalled it again, completely deleted the C:\wamp folder (I already had backed it up before the first uninstall), and then reinstalled it. I started it up, and it WORKED!

The moral is to make sure -- if you're having this same problem -- to completely get rid of your old wamp folder before you reinstall it (I HIGHLY recommend that you back it up first, of course).

I want to thank IanTh for your suggestions. They didn't solve my problem, but I appreciate the time you took looking into this!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.