Getting apps to run in Remote Desktop Server 2008 R2

I've been running server 2000 for quite a long while and am building and testing a server 2008 R2 system (64 bit).  I have installed the Remote Desktop Role and the File Services, Share and Storage Management Role
I installed an app (Omnis Studio) while remotely logged in as administrator.  It runs great.

I created shares for the folder, and registered the app in the Remote App Manager, setting it to Unrestricted.

I set up a user, included him as a member of Remote Desktop users.


The app launches, but fails to load a number of additional files (lt looks like access violations are occurring).  If I make the user a member of Administrators, I get a warning to allow my program to change something in windows, I grant it and it runs normally.  If I remove that member, I'm back to not loading all of the rest of the files my app requires.

 I'm chasing my tail trying to figure out how to make it run.  It seems that it's a permissions issue, but yikes, how many places do I have to go to get something to run?  Any ideas.

I'm not sure what what the Remote Desktop Services Profile is.  It looks like it requires a Domain Controller, which I would rather not install.  A workgroup is fine for our needs.

PS.  This is my first Post, so I'm not real familiar with the Point system.  The right answer will keep me employed so I guess 500 is appropriate.
rdelossaPresidentAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

B HCommented:
the key here is " I get a warning to allow my program to change something in windows"

change what...?

consider turning off user account control, that usually interferes with whatever you want to actually do...

consider setting up a script that actually starts the application as an administrator, with administrative permissions, such as:
runas /user:someadmin "c:\progra~1\someprogram\prog.exe"
(passing the correct password of course)
0
B HCommented:
also consider making those users local admins... if not on a domain, or a domain controller, it might be acceptable to do this
0
rdelossaPresidentAuthor Commented:
User Account Control?
Where is that?
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

rdelossaPresidentAuthor Commented:
I just read about User account control.   I'm in the process of restarting the system.
Running users as admins isn't what I want to do, though it may work out if I only let them run the terminal server.

I'll let you know if the turning the UAC off helps.

Thanks.
0
rdelossaPresidentAuthor Commented:
Turning UAC off didn't do it.
I'll try the scripting in the morning.
Setting the user's to Admin seems pretty lame, but...
0
rdelossaPresidentAuthor Commented:
I will have to figure out how to write a script, test it and then assign it to a user logon.
This is all new to me.  I'll tackle it in the morning.
Thanks for the suggestions, Byron.

If you can think of somethig else, please let me know!
Rob
0
B HCommented:
this page will show you how to make a runas script:
http://www.xinn.org/RunasVBS.html

you might be more interested in the runas.vbscript section there

if you need to really really hide the password from dangerous users, look below that how to encrypt it
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rdelossaPresidentAuthor Commented:
I think the problem was piolot error all along.  No fault of the responses.  Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.