Ubuntu Server Dual NIC - NIC #2 Not Active

I have a Dell PowerEdge 1850 server which has two 1GB NIC cards. After the server install, the second NIC doesn't show up in ifconfig command, nor does it show up in Webmin. Webmin will allow me to add the NIC, but on reboot, the card is gone. I went to /etc/network/interfaces and see no entries for NIC #2. Therefore, I duplicated NIC #1 entries and changed the second set from "eth0" to "eth1". plus, I set the IP address on NIC #2 to a different address. When I do a "ifup -a" command, I get an error message of "duplicate card".

How do I get the server to permanently recognize the second NIC card after reboot?
RayRiderAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
What brand of NICs?  Some 'Plug-and-Play' cards only allow 1 to be installed in a system.  Can you put a different second card in to see if it is recognized?
0
RayRiderAuthor Commented:
This is a Dell PowerEdge 1850 1RU server with built-in NICs. This is a configuration issue as I can add the NIC through Webmin. Webmin is a GUI admintool via a Web browser for the Ubuntu server. This card is visible and responds to ping and also show up when I do a ifconfig command. The problem is when I reboot the machine, the second NIC is not seen again until I go back and enable it through Webmin. I think what is needed is the correct configuration in the /etc/network/interfaces file. This file does not show the second card. The interfaces file is read at boot time and can be force to be read by issuing a "ifup -a" command. When I force ifconfig to be read with ifup is when I get the error message of duplicated card. I had to remove the duplicate entry as there was something wrong. Apparently just duplicating the first NIC card is incorrect even though I changed the name to eth1 in the second set of entries. This is what I entered:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.1.96
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1

# The secondary network interface
auto eth1
iface eth0 inet static
        address 192.168.1.86
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
0
Dave BaldwinFixer of ProblemsCommented:
You specified eth0 again after auto eth1.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RayRiderAuthor Commented:
And, you can call me a "dumb ass" for overlooking that!. On the other hand to be a little fair to myself, I am struggling to see as I have cataracts that I am having removed very soon. Thanks for helping me.

Another question for another day is why didn't the server install prep this NIC card, nor the second SCSI drive?

RR
0
Dave BaldwinFixer of ProblemsCommented:
Don't know the answer to either of those questions.  But those little one letter mistakes have caught all of us at one time or another.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.