403 Error on Apache Virtual Host

I set up a virtual host in apache so that I can test a php website without having to have the website files in the default folder for localhost.

Everything is set up fine in terms of the apache configuration and virtaul host files but the permissions are not right.  What do I set them to and HOW do I set them?

I am using OSX 10.6

Is there a good program for CHMOD for within osx?  Is that what I need to do?
salveoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mick BarryJava DeveloperCommented:
You can just use chmod (from the command line).
Let me know if you're not clear how to use chmod, wasn't clear from your q.
0
GremoryCommented:
If the permissions are your problem you can:

set the owner like this:
sudo chown -R user:group /var/www/

set the permissions like this:
sudo chmod -R 775 /var/www/

the -R stands for recursive, it will  go through all your sub files and dirs.

if your problem are the permissions to edit the files with another user, and have apache own the files at the same time, you should.

1ª Create a new group
2ª place apache user and all the other respective users in the same group
3º simply make the group owner of the dir. with the correct permissions.
0
salveoAuthor Commented:
The chmod thing didn't work and I'm thinking it might be which users have access to it.  Here is what is currently on there.

localhost (this currently works perfectly)
file path: /Library/WebServer/Documents/
Sharing & Permissions
system - Read & Write
admin - Read & Write
everyone - Read & Write

------------------------------------------
localhost2 (this DOES NOT work, this need to be fixed)
file path: /Users/Jason/Documents/Websites/salveosoft/wwwroot
Sharing & Permissions
Jason (Me) - Read & Write
staff - Read & Write
everyone - Read & Write


When I try and add the "system" user to localhost2 path folder (wwwroot) I can't fogure out how to particularly add the "system" user.  It just pulls up a little address book type thing and system isn't an option to pick.



0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Mick BarryJava DeveloperCommented:
>  I can't fogure out how to particularly add the "system" user.

assuming the system user exists

chown -R system /Users/Jason/Documents/Websites/salveosoft/wwwroot
0
GremoryCommented:
Is your httpd.conf file configured correctly? do you have SE Linux enabled?
0
salveoAuthor Commented:
I installed MAMP and it solved the problem.  *Note that only the Pro version fixes this problem.

My guess is that it was a permissions error and had to do with what users had permissions to those files...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.