Running my own mail server, not receiving external emails

Hi Everyone,

I’m setting up my own mail server, so I have one box running SBS 2K3 SP2 (DC) and the other running SBS 2K3 SP2 with Exchange 2003 SP2.

I can successfully send and receive email internally.
I can also send email to external people; however I CAN NOT receive any external emails.

My register is 123-reg as my settings are below:

Domain: domain.co.uk
A record: mail.domain.co.uk  [Static IP1]
MX Record: mail.domain.co.uk 10

My connection to internet is via ADSL using  Modem/Firewall/Switch: SpeedTouch TG585 v7 with one Static IP provided by my ISP


INTERNET
      |
[Static IP1]
      |
Speedtouch TG585 v7
      |
DC 192.168.0.50 and Exchange 192.168.0.51

Any suggestion to get this up and running?
Any comments will be really appreciated.

Many Thanks,
Giraffe
Giraffe_UKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
have you tried setting the mx record with rank =0 instead of 10
0
jerrypdCommented:
it sounds like your traffic is not making it to the server on port 25.
Did you poke a hole in the router for port 25, and did you verify with your ISP that port 25 is indeed open?
Here in NY I had to physically open port 25 with my ISP in order to get mail flowing.
0
Alan HardistyCo-OwnerCommented:
Please visit www.canyouseeme.org and test port 25 to see if this is open and working.
If not, check your Firewall / Router to see if TCP port 25 is open and forwarding to your Exchange internal IP address.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jakethecatukCommented:
Have you asked your ISP to allow inbound SMTP traffic to your IP address?
Have you configured your speedtouch to route SMTP traffic to your Exchange server?
0
KillerbeCommented:
can you telnet your external MX record?
"Telnet mail.domain.co.uk 25"
The cost of the MX record has nothing to do with that. The cost is for setting a preference.
0
Mike ThomasConsultantCommented:
Use http://www.mxtoolbox.com/

Enter your host name and/or IP to see where the problem lies.

0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Make sure you have configured Exchange to receive e-mail for your external domain name - if you send mail to an exchange server and the server doesn't explicitly know it handles mail for that domain, it just throws it away - no NDR or anything.  You're looking to update your recipient policy.  (Other suggestions above could also be your issue).
0
Giraffe_UKAuthor Commented:
Thanks guys.

jerrypd: I just spoke with my ISP tech support, they said they dont block any port. I disabled the firewall on the router until I can get the email flowing.

alanhardisty: from www.canyouseeme.org get error: I could not see your service on 123.123.123.123 on port 25 reason: connection time out.

jakethecatuk: yes, they Eclipse, told me they dont block any port. I have disabled the firewall. Is that enough to allow traffic to Exchange?

Killerbe: telnet failed: Could not open connection to the host on port 25: Connect faield.

MojoTech: from mxtoolbox I receive timeout occured due to inactivity. and all the ports were closed. (not sure if i'm lokking on the right place)

leew: Yes, I have added the domain in question to recipient policy.

I will check both DC and Exchange to make sure there is not local firewall installed.







0
Mike ThomasConsultantCommented:
If everything on mxtoolbox resolves ok but just times out check your ports are open (try telneting to port 25 on your external ip from an external source) if telent works OK and you can see exchange server while telentting check as above (that the recipient policy is accepting for the required domain)

0
Mike ThomasConsultantCommented:
Actually mxtoolbox will attempt to tal to echange for you so just open your ports and make sure they are forwarding to the exchange server.

0
jakethecatukCommented:
You need to NAT your external address to your internal Exchange address.  You will do this on your speedtouch.
0
KillerbeCommented:
It is simple, there is no SMTP connection possible to your server.
Check firewall. Check your virtual SMTP server.
0
jakethecatukCommented:
It may also be set as PORT FORWARDING on your Speedtouch.
0
Alan HardistyCo-OwnerCommented:
From the lack of a Good response from www.canyouseeme.org this would either suggest no port forwarding on your Speedtouch router, or you have not setup your SMTP Virtual Server on TCP Port 25 / the IP Address is set to the wrong IP not All Unassigned.
Check the settings on both and make sure All Unassigned / Port 25 is specified and test again.
0
jakethecatukCommented:
On the Speedtouch, it's set under Toolbox/Game and Application sharing.

Scroll down the list and find SMTP server and choose the device that your is exchange server (the list is the MAC address of all devices on the network).

That should forward all SMTP traffic to your Exchange Server

BTW - TURN YOUR FIREWALL BACK ON!!!!!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Giraffe_UKAuthor Commented:
mojotech: from externaI network, I  can not estabilsh a telnet on external IP port 25. :-(
Recipient policy is fine!
0
Mike ThomasConsultantCommented:
OK then you need to configure your router to simply forward port 25 (or it might be pre tagged as SMTP) to your internal ip address of your mail server, ensure you have no firewall on your mailserver and this will work for you.

0
paritoshjaniCommented:

Try disabling anti-virus and windows firewall if applicable and try telnet from mxtoolbox. Also, be sure TCP 25 forwarding to exchange server (192.168.0.51) is configured from the ADSL.

0
IanThCommented:
if yoor router allows sick your server into its dmz so you don't need to do any port forwarding or firewall changes
0
Alan HardistyCo-OwnerCommented:
Too many cooks!
0
Giraffe_UKAuthor Commented:
jakethecatuk: I added SMTP server to my Exchnage server on Speedtouch, under Toolbox/Game and Application sharing.

Firewall is on now
0
jakethecatukCommented:
[quote alanhardisty]Too many cooks![end quote]

LOL Alan...too true :)
0
Alan HardistyCo-OwnerCommented:
Does www.canyouseeme.org respond happily now on port 25?
0
jakethecatukCommented:
[quote Giraffe_UK]jakethecatuk: I added SMTP server to my Exchnage server on Speedtouch, under Toolbox/Game and Application sharing.[end quote]

And...can you see your SMTP server from the outside world?
0
Mike ThomasConsultantCommented:
At least the cooks are all on the same page though. :/
0
IanThCommented:
Like I said the dmz is the best way to go full stop
0
Giraffe_UKAuthor Commented:
progress guys... I can now sucessfully telnet from external network.
0
Giraffe_UKAuthor Commented:
opsss....
0
jakethecatukCommented:
excellent - can you receive e-mail?

something else to make sure of - make sure that your reverse DNS entry for your IP address matches  the FQDN that you are sending from your SMTP server (this will help prevent your messages being rejected or treated as spam).
0
Giraffe_UKAuthor Commented:
YES I CAN RECEIVE NOW... THANKS GUYS!
0
Giraffe_UKAuthor Commented:
I will assign points shortly....
0
Giraffe_UKAuthor Commented:
very pleased!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.