C++ Drag Drop not working in Windows 7

Hi I have a C++ MFC app that works in XP, but does not allow drag drop in windows 7 (Ultimate)
I have compiled code both under XP SP3 and also Windows 7 using VC2008 C++
The no entry icon appears, and I can find no entry point to my code.
Is there some Win 7 config I need to perform to allow Win 7 drag drop on to my app?
The drop initiates in Windows explorer fine, but OnDragEnter is NOT called in my view class.
Help!
10PintsAsked:
Who is Participating?
 
Pramod BugudaiCommented:
0
 
AndyAinscowFreelance programmer / ConsultantCommented:
Try turning the UAC (user access control) off or logon as administrator.  Does the drag drop now work?
0
 
10PintsAuthor Commented:
Thanks folks
My user is logged on as a user, I have just built a restore app to go back thro my hourly backs and done a diff with the old code that worked and the new code that does not. (Whilst the old code was built using VC6 and the old libraries it did work on Win 7 ( according to my tester!) anyway after doing the minimum possible to run the old code against the V7 SDK libraries using VS2008, and doing a diff I could not see any significant changes re the drag drop stuff.

But what I had forgotten was that during the interval I had migrated the code to VS2008. In doing so I reckon I have the wrong libraries (in VC6 I moved just prior to the migration to using Win Server 2003 SDK, which apparently was the latest version for VC6 .

The working code was using a prior version before this. What was strange is that the Drag drop code was not even being called at all. So I progressed the libs to CS2008
I have now got it running in VS2008 against SDK V7
With no apparent change to the code, the drag drop now triggers!

I think therefore, it must be the libs. There were also other permissions errors that kept flagging up that did not occur on Win7 tests before which we did get around by ticking the shortcut box "run as admin" and by running in an emulated XP mode ( again from the shortcut properties to the exe.)

Do think that the libs thing could cause this? I would have thought that if the wring libs were used then it would either crash, give an ordinal not found.... or even work?
Not just run, but not do anything ...
What do you reckon?

Kind regards
10Pints
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AndyAinscowFreelance programmer / ConsultantCommented:
Older versions of the libraries might still work without error - it really depends on the code and function signatures that are in use.

>>which we did get around by ticking the shortcut box "run as admin"

I still suspect the UAC could be playing a role in the problem, but that also might be in conjunction with the older libs.
0
 
10PintsAuthor Commented:
Thanks Andy, I have checked the UAC and is was set on minimum.
I checked my libraries in VS 2008 ( on XP  - I have SP3 installed)
and they still seem to point to: version 1
which is odd, I have just installed Platform SDK for XP SP 2
and tried the register environment variables from start/all progs/Microsoft Platform SDK for XP SP2/Visual studio Registratio/ Register PSDK Directories with Visual Studio
However on relaunch of VS2008 the env var: $(FrameWorkSDK) (looking in the Macros list) dir still points to v1.0 ...  HELP!?
0
 
10PintsAuthor Commented:
Thanks guys - sorry for tardy reply.
Linking against the correct libs helped a lot, but your advice was invaluable

T
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.