RDP "start the following program on connection" doesn't work

mythulto
mythulto used Ask the Experts™
on
When launching a remote desktop session, I want a specific program to start automatically upon login. I have set the "Start the following program on connection" field in the RDP settings.  I login fine, but the desired program doesn't start automatically. Even with a simple program like notepad, no go. I've tried notepad, notepad.exe , "notepad" and "notepad.exe".

The computers are simple Windows XP Pro SP3, no domain controller here (so no domain controlled profiles, etc).

I've tried using gpedit.msc to set User configuration->Administrative Templates->Windows Components->Terminal Services->Start a program on connection, but no luck.

I've tried this to-and-from two different machines in the office. Same deal.

Suggestions?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You have to specify the full path to the program (ie: the path to the program on the TARGET computer), as well as the program name.

So instead of "notepad.exe" you could specify
C:\windows\system32\notepad.exe
or
%SystemRoot%\system32\notepad.exe

Author

Commented:
adatole: That does not work either. Tried both of your suggestions, but with and without quotes around them (Microsoft recommends quotes). I tried "C:\windows\system32\notepad.exe" right from Start | Run and it worked, so I know there's nothing wrong with Notepad.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

joensw: That doesn't seem to address mythulto's issue. He isn't able to START a program.

I'm still digging into it, by the way.
I know you said both machines were XP Pro. But this caught my eye so I thought I'd pass it along: "start program" doesn't work on Vista or win7 targets unless you have the "Terminal services" role installed.

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/2b55ff33-3706-44e4-88a6-19c0b140cd25

You said there was no domain in this situation, so there's no GPO either, right?

On thing to try is to start RDP via the command line
   Start - Run - "mstsc /admin"

it's not supposed to make a difference in XP, but it's worth a shot since we are grasping at straws here.

Otherwise, I can't see why it wouldn't work.

Author

Commented:
joensw: please read my posts before you answer and please don't answer what's already been covered. Your responses are of no value and getting response notifications are a waste of my time and clog my post with worthless bulk.
Thank you.

Author

Commented:
Update:
I went to a the office of a completely different company and tried this on several computers there. Same problem. I can login with RDP just fine, but no amount of tinkering with the RDP settings will launch a program upon login.
Make sure in the Terminal Server connections settings under tscc.msc on the server you are attaching to you allow the program to run from that setting on the RDP.




tscc.jpg

Author

Commented:
fsmccowan: Forgive me if this was not clear. The connections I am running are Remote Desktop between XP workstations -- there is no Terminal Server. XP does not have the tscc.msc snap-in.
My fault for reading too quick...

Part of the  problem is that XP is not setup to do this.   You could try putting the program and path in the old standby: Start menu>Start Up folder...but then you would have to make sure the users logout cleanly and it would still allow them desktop access which is what I assume you are trying to limit.

Author

Commented:
fsmccowan: Thanks for your response. I was beginning to suspect this was something XP was not capable of -- it's just that in all my Google searching, I've never seen it stated. Thanks for setting the record straight.

It appears your suggestion is the best option for my setup.

Thank you.
I'm having the same problem but my tscc is all grayed out in the Environment tab. Anyone have any thoughts?

Thanks
tscc.JPG

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial