We help IT Professionals succeed at work.

Safari beach ball when I open it

Every time I open Safari I get the beach ball for about 5 minutes. then Safari works fine.
It happens on my iMac and my MacBook Pro.
I have tried all the defaults, reseting safari, upgrading to 5, disabling plugin, javascripts, etc.
When I try to disable the RSS of the bookmarks bar safari crashes and need to force quit it.
Comment
Watch Question

does it only happen in safari what happens if you try something like firefox? have you done a defrag recently or tried one. Also you can do a permission repair there may be something corrupt
bstaudCEO

Commented:
Among the things to check would be whether your system has a properly functioning DNS. Let us see what trying a different browser gives you - like Firefox...

Author

Commented:
this doesn't happen with other browsers. Tried Firefox and chrome. The problem happens when I open safari, it delays about 5 minutes, and then it works fine.

Commented:
Since you have done a full reset, maybe it is time to toss all the preferences files as well,
 "com.apple.Safari.plist" in your acount -> library -> preferences. You might also toss the RSS preference  "com.apple.Safari.RSS.plist" as well.

But many things can cause this. I would be sure the cache really emptied. Also do you default to opening a lot of pages, and could one of the pages be bad and that is holding it up?

And in the obvious section repair disk permissions, something might be broken in one of the files and it takes that long to time out.

Also, be curious to know if you create a new user and run Safari there, does the same problem happen. Might narrow it down to a bad app or a bad preference file.

Author

Commented:
I tossed the .plist with no luck. Safari is set to open a blank page when it is opened.
Cashe is emptied, I repaired the permissions and nothing.
I created another account on the os and when I open safari in this account it opens immediately with no problems.

Commented:
OK, last point is very useful. It seems that it IS something in your account that is causing the problem, and not Safari itself.

Would it be too difficult to migrate your account to a new account and just delete the current one? Then you could rename it back to the original name. Drastic, but it may be the quickest way to correct the problem.

By the way, I found this on CNet's site:


Slow launching: Clean startup routines:  There are a number of routines Safari has to perform each time it is launched, and making sure there aren't excessive steps in these routines -- by reducing the number of files in certain locations or periodically deleting some folders altogether -- can make for fewer bounces in the Dock.

The ~/Library/Safari (the tilde [~] represents the current home user directory) folder is one of the locations you should check, because Safari checks it as well when launching. Here the browser stores bookmarks, recent downloads, form values, history and favicons, the small icons that appear next to the URL for some sites. Favicons, in particular, can cause sluggishness when starting Safari and when loading pages. Try dragging the folder Icons -- where these icons are cached -- within the ~/Library/Safari folder to the trash and restarting Safari.

Hope that might help as well.

Commented:
Hit post too soon. I had a bit more:

Also suggest a check for an errant plug-in by turning them off. Go to the Safari menu, select preference, and then Security. Uncheck the "Enable plugins" item and restart. See if that helps. Might narrow it down to a bad plugin.

You can also disable Java and Javascript here as well to see if either of those may be causing the problem.

Lastly, consider removing any third party add-ons if you have any. Each add on uninstalls its own way, so if you have added any, consider removing them one at a time to see if any make a difference.

You can see the Cnet article here: http://reviews.cnet.com/8301-13727_7-10328447-263.html

Author

Commented:
Tried everything listed here. Same problem. I uninstalled xmarks for safari. Funny thing is that when I go to the safari preferences and try to disable under the RSS tab the bookmarks bar, safari crushes.

Commented:
OK, so perhaps the problem is actually with one or more of the RSS feeds. There is something there. Do you have a lot of RSS subscriptions? I am wondering if they are taking up all the time at the start downloading ? Can you unsubscribe in Safari to  them and see if that changes anything?  (Ctrl-Click the bookmark for the feed and select delete.)

Ok, try this one: Go to Macintosh HD->Library->InputManagers and see if there is a file there called "SafariBlock" (or something similar), and if so, delete it.  (You will need admin privs to do that, and if you find it,  I suggest a restart after removing it.)

Just curious, have you tried deleting Safari and reinstalling it? Can't really believe that would make a difference, but might be worth a try if nothing else works.

I am guessing the best way left is to create the new account (where you know it works OK), move all your stuff into the new account, and delete the old one, then rename the new one to the old name if you care.

And just to be sure, you did all these things below, right? This is the typical speed up list:
Empty the Cache
Reset Safari
Erase Website Favicons
Delete the Preferences File
Disable Add-ons
Adjust the 'Render Before Display' Timer (enter into a terminal window: defaults write com.apple.Safari WebKitInitialTimedLayoutDelay 0.25) (Although this last one is not really part of your problem I am sure.)

I will keep looking for possible causes if all this does not help.

Author

Commented:
Ok I found the problem but can't correct it. I have thousands of RSS feeds on safari. But when I try to delete one or more safari crashes. Is there another way to delete them?
Commented:
If you click on the Bookmarks item (the small picture of the book in the upper left side of the browser) it will open all bookmarks. In their, there is an item for RSS feeds. See if you can delete them like that.

Otherwise, you can "edit" your bookmarks files using a text editor, find the RSS feeds, and deleting them. Look in user/Library/Application Support/Safari folder for the Bookmarks.plist, and open it with say TextEdit. It will look a little strange, but you should be able to make out your RSS feeds.

You could also move it out of the folder, relaunch Safari without bookmarks and double check this is the problem. If it works, you might be able to import the file again (have not tried this.)

But I suspect that many feeds may indeed stop the browser until it loads them all.