We help IT Professionals succeed at work.

Audio not working over RDP to a HYPERV VM

I have got a hyper vm terminal server running which i need to be able to get audio to work on the local machine that is using the rdp session to the vm but when i enable the audio to bring it to this computer i cant get any audio through can someone hopefully help me with this thanks in advance
Comment
Watch Question

What is the Client OS ?  Hope you verified volume control panel.

Author

Commented:
the client os is windows xp and i can get sound on the local machine without issue just when i do a rdp session to the server 2008 terminal server
have you made sure that you have audio enabled on the 2008 TS (i.e. - is there a soundcard listed under hardware on the 2008TS).

Author

Commented:
There is no sound card as it is virtualised
OK - so if there is no soundcard installed in the 2008 TS, how do you expect it to generate sound that can be sent back to the XP workstation?

A TS session produces all graphical and sound from the server that is hosting the TS - in your case, your virtual server.  Bottom line is, without a soundcard installed, 2008 TS will only send keyboard beeps back to the client connecting to it.
Top Expert 2012

Commented:

Author

Commented:
i have a sound card installed in the physical server but with hyper v not emulating sound cards it shows as there being no audio device installed on the virtualised ts
Top Expert 2012

Commented:
Have you read over the links posted.

Author

Commented:
i have read through both links and i did look at them yesterday before posting on here but for some reason when i go into the sound control panel applet it doesnt give me any options everything is greyed out as per attached image
SoundCPL.jpg

Author

Commented:
also attached is a screen shot of the windows xp sound cotrol panel applet
xp-sound.JPG
Top Expert 2012

Commented:
Commented:
found that the issue was that client audio mapping is disabled by default as per the following link

http://www.cyberciti.biz/faq/windows-server-i-donot-hear-sound-over-rdp/