We help IT Professionals succeed at work.

Exchange 2010 Offline Address Book broken

Christophermagee
on
Hello Experts,

We had our exchange 2007 server die and we got it back online again enough to replace and move everything onto a new exchange 2010 server.  Everything has gone well except for the Offline address book. When i tried to create the OAB from the management console everything would go fine until i got to the webdisrtibution. When click add server for webdistribution it would not find the local server but keep looking at the old server for web distribution. So I created it manually using in the shell but the clients are still not able to connect to it. This is the command i used in exchange powerdshell    New-OfflineAddressBook -Name "New OAB" -AddressLists "\Default Global Address List" -Server SERVER01 -VirtualDirectories "SERVER01\OAB (Default Web Site)"

The error clients are giving are from outlook 2007 0x8004010F and from outlook 2010 0x80190194.

Thankyou in advance
Comment
Watch Question

BusbarSolutions Architect

Commented:
open the EMC
go to mailbox
go to Offline address book
right click on NEW OAB and properties
in the distrbituion click enable web distrbituion and add the Exchange 2010 server
then ok
after that right click on new oab and update

Author

Commented:
Cannot add the exchange 2010 server as it does not find it. It brings up an error saying it cannot find our old server.
Solutions Architect
Commented:
can you delete the old server from Active directory
open adiseidt
connect to configuration
open services
Exchange
expand the admin group then servers and delete the old server

Author

Commented:
Sorry for the late reply, it was a long weekend here.

That worked and allowed me to create the OAB from the console instead of from the power shell however the outlook clients still cannot  download the offline address book and have the same error messages as above.

BusbarSolutions Architect

Commented:
did you rebuild the OAB, it will take place every day at 5 AM so it takes time.
also did you configure the internal URL o nthe oab virtual Directory!

Author

Commented:
Once i created the OAB i told it to update.  I tried going to http://Mailserver/OAB however had no luck there as well and get a forbidden access is denied.

I did notice in the OAB directory there are 100+ lzx files is that normal?

Thanks again

Author

Commented:
Also forgot to mention I did check the internal URL and it seems to be OK.
BusbarSolutions Architect

Commented:
what kind of authentication configured on the OAB virtual directory

Author

Commented:
Everything is disabled except for windows authentication currently.