We help IT Professionals succeed at work.

Outlook 2003 OAB sync error - 08004010F  with Exchange 2007

emtechadmin
emtechadmin asked
on
Hi experts

I am eagarly looking  for a solution for my outlook 2003 clients thats communicating with my Exchange 2007 SCR. All Outlook 2003 clients showing 08004010F when sync / send and receive with Exchange server. Attaching screenshot. OAB syn error in outlook 2003 client.
Thanks in advance
Vivek
Comment
Watch Question

Commented:
Have you setup public folders yet? Legacy clients retrieve the OAB from the public folders. If this is a migration then make sure you sync those pulic folders over and they are working,
MASEE Solution Guide - Technical Dept Head
Most Valuable Expert 2017

Commented:
EE Solution Guide - Technical Dept Head
Most Valuable Expert 2017
Commented:
THis is the error which is associated with Offline Address book not available to clients for download.

It happens b'coz of many reasons.

Many of the times customers end with support call with microsoft.

but let me suggest you general steps to be followed.

1) make sure that on the property of mailbox store Offline Address Book is assigned properly
2) increase diagnostic logging by going to server property on system manager for the counter OAL Generator
3) try to rebuilt the OAB
4) watch out for errors in application logs
5) try creating another OAB pointing to another Exchange server
6) associate newly created OAB on the properties of mailbox store
7) if all these step fails

refer following article possibly we need to reset system folders

http://support.microsoft.com/kb/822444/ 
 
http://support.microsoft.com/kb/275171/EN-US/ 
 


Author

Commented:
Hi.

My mailbox database associated with default OAB.
When I rebuilt OAB it generated error event 9334 along with warning 9395. Attching screenshots.
err-9334.JPG
Warning-9395.JPG

Author

Commented:
And this problem is appearing only with outlook 2003 clients. Outlook 2007 working without any errors
MASEE Solution Guide - Technical Dept Head
Most Valuable Expert 2017

Commented:
Have you had a look at this?

http://technet.microsoft.com/en-us/library/dd285503(EXCHG.80).aspx

and let me know
Commented:
Ensure you have enabled PF distribution of the OAB as this is where the Outlook 2003 clients will look.

Do the following and paste the data (edit out/replace private info):
Get-OfflineAddressbook | ft identity, publicfolderdatabase
get-mailboxdatabase | ft name, *public*
This problem generally happen so nothing to be worried about it. But, if your PST has been damaged then you need to repair it. http://www.nucleustechnologies.com/Microsoft-Outlook-Mail-Recovery.html

Commented:
@ComputerBeast - I think you have posted on the wrong question. OAB download has nothing to do with PST.
Top Expert 2010

Commented:
Hi
I had the same issue at one of my clients.
http://support.microsoft.com/kb/905813 >> didnt fix it.

My guess is this has something to do with OAB Alias in 2007.
E2003 would allow you to have blank spaces in OAB
 - like OAB Version 2
- OAB Version 3

2007 doesnt take blank spaces in alias.

Go to Tools > Open PF Management Console.

----
These guys here have some ideas on rebuilding OAB
http://forums.msexchange.org/m_1800402025/mpage_1/key_/tm.htm#1800402189
Top Expert 2010

Commented:
I think this is a better solution > Create a new OAB
I will have to test this though.

http://www.theemailadmin.com/2009/06/troubleshooting-error-code-0x8004010f/

Commented:
Like I said before, only Legacy clients (2003 and lower) get their OAB's from the Public Folders so you should listen to MegaNuk3 and check that your Public Folders have been properly created and if multiple servers exist that they are replicating.

Is this a clustered exchange rollout or are you replicating your databases to a secondary server?  Those errors you posted kind of seem like you are running a cluster or that you have not done the steps posted by someone else:
http://support.microsoft.com/kb/905813
(See method 1 for Exchange 2007)

Author

Commented:
Sorry MegaNuk3. I will paste the  output by today itself.

Sunny C7, Thanks for the comment, OAB rebulding is not a solution, I had created and assciated new OAB to my mailbox database. But still I'm getting the same error.

Sean D76, Thanks for the comment,  Yes, This is a CCR cluster. I had done steps mentioned in above url(KB905813) while implementation time itself.  

Author

Commented:
Hi MegaNuk3: please see output of Get-OfflineAddressbook | ft identity, publicfolderdatabase
and get-mailboxdatabase | ft name, *public* in attached txt. Kindly advise.


[PS] C:\Documents and Settings\Administrator>Get-OfflineAddressbook | ft identity, publicfolderdatabase

Identity                                PublicFolderDatabase
--------                                --------------------
\Default Offline Address Book           MAILSERVER\Public Folder Group\Publi...
\Almaya All Users                       MAILSERVER\Public Folder Group\Publi...


[PS] C:\Documents and Settings\Administrator.ALMAYAAE>
[PS] C:\Documents and Settings\Administrator.ALMAYAAE>

[PS] C:\Documents and Settings\Administrator>Get-Mailboxdatabase | ft name, *public*

Name                                    PublicFolderDatabase
----                                    --------------------
Mailbox Database                        MAILSERVER\Public Folder Group\Publi...
Maildata2                               MAILSERVER\Public Folder Group\Publi...
MailData3                               MAILSERVER\Public Folder Group\Publi...
MailData4                               MAILSERVER\Public Folder Group\Publi...



oab-status.txt

Commented:
That looks OK, what about
Get-Mailboxdatabase |ft name,OfflineAddressBook

Author

Commented:
please see the result.
[PS] C:\Windows\System32>Get-MailboxDatabase | ft name,OfflineAddressBook

Name                                    OfflineAddressBook
----                                    ------------------
Mailbox Database                        \Default Offline Address Book
Maildata2                               \Default Offline Address Book
MailData3                               \Default Offline Address Book
MailData4                               \Default Offline Address Book

Commented:
Is this problem still occuring?

Author

Commented:
Some how it is resolved. I don't know which solution worked well. I had created another OAB.  Also I rebuilted Default offline address book.   Whether this will take days to compleate???

Commented:
Thanks for the update and the points.

OAB rebuilds take minutes not days... Oh well, glad it is all working now for you though.
Top Expert 2010

Commented:
So you created a new OAB and rebuilt according to these steps ?

http:#32969867
http:#32969877

You had said earlier that rebuilding OAB is not a solution
http:#32991467

Please confirm what steps you tried which worked.