We help IT Professionals succeed at work.

How do I create a Windows share that doesn't prompt for a password?

I am running a windows 2008 server. I need to create a share that gives everyone access without asking for a password. I have created one and have given the share "everyone" permissions and security "everyone" only. Still prompts me.

Is there any way to have the share open without the prompt?
Comment
Watch Question

Commented:
Hi  you can do the following

Go to the default Domain security Settings of your server Under Local Policies - Security Options

Enable this feature :

Accounts : Limit Local Account user of Blank passwords to console logon only
If the server is a domain controller its hard to accomplish. If you have a workgroup setup you just need to set up a user account on the server that matches the client computer user account.
You can perform the following steps:

 

1. Navigate to Control Panel > Windows Firewall, enable "File and Printer Sharing" in "Allow a program through Windows Firewall"

2. Navigate to  Control Panel > Network and Sharing Center, in the Set Network Location dialog box, change it to Private.

3. Make sure Network Sharing and File Sharing is turned on. If they aren't, click the down arrow next to them and click the option that turns them on.

4. Make sure Password protected sharing is turned off. If it isn't, click the down arrow next to them and click the option that turns it off.

5. Share one folder you want, add everyone in the permission tab.

 

Once this finished, you can try to access the shared folder through IP  address of the server, if you get a prompt for username and password, just input some letters(not need to input in the password box) in the user box, click ok you will get the shared folder.

Author

Commented:
Hi fatnasa2010,

That worked thanks. However now it has opened ALL the shares on the server.

Is there a way to limit this option to only certain shares?
Commented:
Two ways. You can Add "Authenticated Users" so any user in a domain can log in, or use Anonymous Logon which allows open to everyone. Carefull while you use this options.

Author

Commented:
Thanks it worked