We help IT Professionals succeed at work.
Get Started

Problem with upgrading a AD, 2008 forest level, to a Windows Server 2008 R2 level.

452 Views
Last Modified: 2012-05-09
I am running a AD with Windows Servers 2008, with two domain trees in one forest. I am trying to add a Windows server 2008 R2 to the forest, but I get the error message that first need to run "adprep.exe /forestprep" to prepare the forest. But when I run "adprep.exe /forestprep" (64bit version) from the Windows Server 2008 R2 DVD, on the domains schema master, NOTHING happens. I get no confirmation or any error messages indicating how things went. And when I try to run dcpromo on the R2-server once again, I still get the same errormessage as before - that I first have to run adprep on the forest...

I have been seeing some similar threads on the internet, but I couldnt find anything helpful.
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 23 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE