We help IT Professionals succeed at work.

Unable to send to exchange accounts with outlook anywhere

jerminate
jerminate asked
on
I have Exchange 2010 with Outlook anywhere enabled. My enviornment consists of laptops off my domain so I'm using outlook anywhere to conect via http to my echange server. Everything connects up in Outlook 2007 and Exhchange shows online but when I try to send emails to another exchange account I get. "The Connection to MS Exchange is unavailable. Outlook must be online or connected to complete this task."

The interesting thing is I'm able to send to ceratin accounts in exchange that I've sent to befor setting up Outlook anywhere. Also get the Offline error when trying to access the global address book in Exchange.

It's got to be an address book issue.. right? The laptops I setup on my domain and then moved off site work fine. It's the new off-site systems that are having the issue.

Thanks!
Comment
Watch Question

Commented:
Do tools-->send/receive-->Download Address Book

Do you get an error logged in your "Sync Issues" folder? What is the error?

Author

Commented:
Yup 0x8004010F object cannot be found

Commented:
To me it sounds like your externalURL for the OAB is invalid that's why external clients can't find/download it. To confirm this:

Test outlook autoconfig.
With outlook open do: Hold down the CTRL key and then right-click on the Outlook icon in the system tray(near the time on the bottom right-hand side of the screen)-->Test e-mail autoconfiguration-->enter a valid e-mail address and password-->make sure "Use AutoDiscover" is the only one ticked-->Press Test and then look in the Log for the OAB URLs

Author

Commented:
Wow! Lots of stuff there. The last entry is a server recored lookup failure for the server I was testing to which happened to be my Exchange Server. I did get a SSL Cert name mismatch popup that I did an Ok to get past. In testing further, I can send emails to anyone that I have sent mail to previously before adding the outlook anywhere settings. It's only the new addresses that I get the Offline Message.

Commented:
Does it show 2 OAB URLs? One under "Protocol: Exchange RPC" and the other under "Protocol: Exchange HTTP" ?

Author

Commented:
I don't see any OAB URLs.

Commented:
Not even under the "Results" tab?

Can you post a screenshot and edit out private bits with MSPaint if you want?

Author

Commented:
All it says is Autoconfiguration is unable to determine your settings.
I'm connecte via VPN to my domain right now. I can disconnect and try to test again.

Author

Commented:
Same Results. Unalbe to Determine Settings

Author

Commented:
Screen shot
Doc1.docx

Author

Commented:
Commented:
OK, and under the "Log" tab

does it show it trying to connect to autodiscover.yourexternalmaildomain.com and failing?

A quick way to sort that out/test is to add autodiscover.yourexternaldomain.com to your HOSTS file and point it at your external router/internet address.

Can you get onto OWA from the internet / not the VPN?

Commented:
So when you are connected via the VPN, is outook showing as connected via TCP or HTTP? Can it also not download the Address Book when connected via the VPN? Does it give the same error?

Author

Commented:
OWA woks fine from anywhere.

Author

Commented:
All of these laptops have not been joined to the domain so all are connected via http.

Author

Commented:
Can't pull the Address in VPN or web

Author

Commented:
Do u need more info?
Commented:
autodiscover.yourexternaldomain.com to your HOSTS file and point it at your external router/internet address.

the above IP address should be the same one you are getting for your owa server.

then do the autoconfig test again and should succeed and show some OAB URLs

Author

Commented:
I appreciate the help, I'll have to pick this up in the moring with your last reccomendation. I'll let you know hte outcome. Again. really appreciate it.

Author

Commented:
Turns out it  was DNS related. The off site systems wen't able to pull the OAB due to DNS. I added the entry for the Exchange Server and Bam! Good to Go. I appreciate your help.
Commented:
yep, adding it to your HOSTS file would have been the quickest way to prove that you needed to amend DNS.

Commented:
Thanks for the points, glad we got it all working.