We help IT Professionals succeed at work.

Import-Module ServerManager

Hi Guys,

I am having a LOT of trouble installing Exchange 2010 on my brand new Enterprise 2008 R2 server.

I am trying to follow this article:

http://www.messagingtalk.org/exchange-2010-rc-quick-installation-guide

It wants me to, in Power Shell, run: Import-Module ServerManager

When I run that, here is what I get:
PS C:\Users\administrator.CWB> Import-Module ServerManager
Import-Module : The specified module 'ServerManager' was not loaded because no valid module file was found in any module directory.
At line:1 char:14
+ Import-Module <<<<  ServerManager
    + CategoryInfo          : ResourceUnavailable: (ServerManager:String) [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand




Any ideas?


Also, I installed Exchange 2010, but when I open the EMC, you can see the error in the attached message. I've tried every fix I can find on the internet.



I'm glad Exchange 2010 is so awesome! NOT.


wtf.jpg
Comment
Watch Question

Awarded 2009
Top Expert 2010

Commented:
I would suggest it's not R2 you have installed.

Check here for the pre-requisites.  Try the non-R2 versionof the commands and see what happens.
Awarded 2009
Top Expert 2010
Commented:

Author

Commented:
demazter, you were correct. I'm a moron :)

I seriously thought I had R2.... woops!

Exchange 2010 installed and working properly!!
demazter i Have win2008 R2 but problem is same plz advice