We help IT Professionals succeed at work.

VMWare VirtualCenter Server Service (vCenter) not starting on startup

We have a server running vCenter on Windows 2003 Enterprise and it isn't starting the vCenter service (formally called VMWare VirtualCenter Server Service) on startup although the service is set to "Automatic".  I've tried changing the permissions on this service from Local System to Network Service to the domain administrator and none of them work for startup.

has anyone seen this before?
Comment
Watch Question

Top Expert 2005

Commented:
Where is the Database?  If it's not reachable then this service won't start.
Top Expert 2010

Commented:
Concur with Netman66; check your ODBC connection to your DB (if it's remote). If it's a local DB, something else is happening. There was a recent thread on here that may provide further assistance.
http://www.experts-exchange.com/Software/VMWare/Q_26074883.html?sfQueryTermInfo=1+center+servic+start+virtual+won%27t

Within this thread is a link to:
http://www.ozvms.com/index.php?option=com_content&view=article&id=553:virtualcenter-vpxd-command-line-switches&catid=50:tech-tips&Itemid=49

...on how to reset the DB pwd (which may be the cause of your issue as well). The cmd is:
vpxd.exe -p

Regards.
~coolsport00

Author

Commented:
This sevice does start when i manually start it, just not when the server is rebooted although the service is set to "Automatic" startup.  I thought it might be a delayed start issue but I've now waited over an hour and the service for vCenter still isn't up.
Top Expert 2010
Commented:
Try to reinstall vCenter and let me know...

~coolsport00
Top Expert 2005

Commented:
Drill down to this folder in a CMD window:

C:\Program Files\VMware\Infrastructure\VirtualCenter Server

Execute the following command:  vpxd.exe -p

Enter your new Admin password.

If the service now starts, then you'll need to disconnect and reconnect all your ESX hosts in the client.

Author

Commented:
Tried Netman66's suggestions and that didn't work.

Top Expert 2005

Commented:
Spool up the latest vCenter build and maybe it will repair the issue.  If it doesn't then you can launch from Add/Remove Programs the repair functionality by selecting the install and clicking change.

This should allow you to re-enter your new password.
Top Expert 2010

Commented:
As I suggested earlier...

~coolsport00

Commented:
If your vCenter is using the SQL Express database (that is, a local database), then you need to make the vCenter service depend on the database service.  When vCenter tries to start, but there is no DB available, you will see these issues.

To set service dependencies:
http://support.microsoft.com/kb/193888

Commented:
I have seen this behaviour before and crudely got around it by setting the vCenter service to Automatic(Delayed) startup.  This worked for me but I accept that this is probably not the ideal solution.

I think that the solution from Kaffiend sounds the best.

Author

Commented:
@Kaffiend.  Set up the dependencies as you illustrated and it didn't work.  Rebooted and the vCenter service didn't start up.

I'm going to try and reinstall vSphere.

Commented:
Please don't do that (re-install vSphere)  vCenter, maybe, but I think it may not need to come to that.  The reason is that I have run into this issue before, and setting the dependencies worked to resolve it.  

The vCenter service - is it running under a service account's credentials?
And, could you list the dependencies that you set?  (The database that vCenter uses, it is a local database, is that correct?)

Top Expert 2010

Commented:
Reinstalling vCenter, though a last resort, is a non-issue...it doesn't affect anything, except from being able to log into vCenter temporarily. It's a quick fix...the install is over and done with in 5mins, as long as the DB hasn't changed. The only problem is that it doesn't solve why this happened in the 1st place. So, your choices are to spend more days upon days trying to resolve this, or get it back up and going. And, just as a disclaimer...though reinstalling more than likely will resolve this, it's certainly a possibility that it may not. But, as noted...it's a quick install.

~coolsport00

Author

Commented:
Reinstalling did the trick.