VMWare 4 Error parsing the servers clients.xml file

BCHCAdmin
BCHCAdmin used Ask the Experts™
on
Just today when I tried logging into the vcenter client (VMWare 4) I am getting an error that says: "Error parsing the server xx.xx.xx.xx Clients.xml file".   I was in a few days ago to it.  I am running Windows XP on my client - the vcenter server is a windows server 2008 VM.   I read somewhere it may be related to a windows update?  Anyone have any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Have you installed VMware ESX / ESXi 4.0 Update 1 ?
This was caused by a .Net 3 SP2 patch (from last patch Tuesday) that appears to break the vSphere client. I did NOT appear to have problems with the vSphere client from my Windows 7 workstations, but a customer of ours reported problems with Windows XP SP3 and Server 2003:
 
If you’ve already installed the .NET 3 patch, then uninstall  KB980773 to fix.

Here's a discussion about the issue:
http://communities.vmware.com/message/1549684

Also ¿ vSphere 4.0 Update 2 released yesterday (along with an update for ESXi, vCenter Server, Update Manager, and Consolidated Backup. I have NOT verified yet if the vSphere client included in Update 2 fixes the problem with the .NET patch

Author

Commented:
Thanks - that resolved the problem.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
Is there not a vmware fix for this issue? Surely we're not expected to play the shell game with various MS patches and versions of the vsphere client?

btw, removing KB980773 worked for me...
If you are running a version of the vSphere client from Update 1 or later you were not affected.  This was the same error seen with the original version of the vSphere 4 client with x64 operating systems.

Here is the official VMware response (KB article) to the issue:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022611

Commented:
I just updated my computer this morning and received the same PARSING error described in this thread. Removing update:  KB980773  worked for me as well.

Thank you.
Thanks a lot!
Worked like charm. Removing this KB worked for me. Have to exlude from WSUS update.

Commented:
Removing the update fixed it for me too.  Thanks!

Commented:
thanks.  repped
Top Expert 2010

Commented:
Just a minor correction - it was a .NET 2.0 SP2 KB/patch, not .NET 3.0 SP2. I couldn't find it on mine until I selected 'updates' in Add/Rem pgms. It wasn't under the .NET 3 install, but .NET 2. Just wanted to clarify to assist others who may need it.

Regards,
~coolsport00
Download the vsphere 4.0 update 1 or update 2 client from www.vmware.com and install it. This issue is fixed in the client version of vsphere 4.0 u1 & 4.u2.

Kind regards,
Sandy

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial