We help IT Professionals succeed at work.

URGENT: Solaris virtual printer lpd printing setup

Craig Sharp
Craig Sharp asked
on
I need to setup a virtual printer in Solaris 10.  The printer is called vprint1.  I have tried using:

lpadmin -p vprint1 -s hqoptio\!pr1/LPT_PASSTHRU -I all

The printer is setup properly but is not functional using lp -d vprint1 testfile.  I also tried setting up a normal print queue and then generating the virtual printer but still no good.

I am looking for the proper steps to setup and make vprint1 work correctly when a user prints to the printer.  I expect that the output will come from the hqoptio server which is properly working and maintains the print queue.

This is very urgent so any help would be greatly appreciated.
Comment
Watch Question

Please have a look at my answer in http:Q_21576890.html   and http:Q_23204262.html
Craig SharpLead Enginneer - Unix Server Team

Author

Commented:
Thank you for your assistance.  We figured it out.  We only needed to generate the remote and not the local queue.  We send data to Optio from Oracle and the local queue was causing the remote to be disabled.